Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] APN Defaults Wrong - Tricky Problem

OP Murrfk

13th December 2014, 05:17 PM   |  #1  
OP Junior Member
Thanks Meter: 11
 
29 posts
Join Date:Joined: Jun 2011
I have two Samsung Rugby I547 phones. One was originally on the Bell network, and the other was originally on Bell's sister network Telus. I have used ODIN to flash them both to stock Telus firmware. Both have been sim unlocked to work on the MTS (Canada) network. So far so good. However, when I tried to enter the APN settings for MTS on ONE of the phones, they would not save. If I then reset it to defaults, three default APNs come up on that phone, none of which are Bell, Telus, or MTS. One is a fidonet APN (which I presume is Fido a sister of Rogers network, which the phone was never on) and there are two other APNs that don't seem to be related to any typical network). My reading indicated that APN settings will not save if they do not match the SIM card.

For reference, when I ask the other phone to reset to defaults, none come up with an MTS sim card installed. I can manually set up the APN and save it.

So I did some research and found that default APNs are located on the APNConf. file in the /etc. So, I modified the APNConf file to include MTS settings on the phone that was blank, and saved it using root explorer, to the /etc folder. And, using the phone that had blank defaults, when I now restored to defaults, MTS showed up. Success on the phone that worked.

So, thinking I had this solved and that some settings in that file must have been wrong, I copied the same APNConf file to the problem phone. With and MTS sim card installed, the defaults still came up as fidonet and the two others.

Thinking there was something wrong the the sim card, I got a replacement. It did not fix the problem. So I reinstalled the original Bell firmware using Odin. Still the same default fidonet, and inability to save the correct settings for MTS Apn.

I have deleted all the APNs. MTS will not save. The only way I can get data to work on the phone is to MODIFY the Fidonet APN, and NOT change the MCC (or MNC?-Cant remember which) setting. When I do this, changing all the settings but one, I can get the settings to save and data worksf but MMS messages will not send.

I thought that default APN were stored on the APNConf file, and what the system does is find the ones that match the MCC and MNC on the sim card, and take the rest of the information from the APNConf. But this does not seem to be happening with the one phone. If anyone has any suggestions or input as to how this works and what might be happening, I would appreciate any thoughts.
14th December 2014, 05:33 AM   |  #2  
OP Junior Member
Thanks Meter: 11
 
29 posts
Join Date:Joined: Jun 2011
I wonder if there might be something over riding the default apn settings such as is described in this thread:
http://forum.xda-developers.com/show....php?t=1527434
Post Reply Subscribe to Thread

Tags
apn, apnconf, data, mms
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes