FORUMS
Remove All Ads from XDA

[Q] Problem with app. Why did restoring backup work when nothing else did?

17 posts
Thanks Meter: 10
 
Post Reply Subscribe to Thread Email Thread
Hi,

I had a weird problem with an app (The Times and The Sunday Times) on my Xperia Z2 Tablet yesterday. Although I managed to fix it eventually, I was wondering if anyone might be able to shed some light on what happened.

The tablet had been repaired under warranty. Before I sent it off, I did a full Titanium backup, unrooted, and reset to factory defaults. As part of the repair, Sony updated the firmware from 17.1.1.A.0.402 to 17.1.2.A.0.314 (17.1.2.A.0.314 was released whilst it was out for repair). Both firmwares are based on Android 4.4.2.

I reinstalled all my user apps (not system apps) by restoring a Titanium backup, after which the The Times and The Sunday Times app was working. I used it several times, then yesterday it froze when loading. Killing the app from the recents and opening it again didn't work; this time it wouldn't load (the icon on the Nova Launcher desktop glowed for a few seconds, then nothing happened).

I then tried the following, killing the app from the recents menu before each attempt:
  1. Clearing the app's cache.
  2. Clearing the app's data.
  3. Uninstalling the app and reinstalling.
  4. Uninstalling the app, searching the entire device for the app name using solid explorer (rooted), removing any left over files, and reinstalling the app.
  5. Uninstalling the app, running SD maid, and reinstalling the app.
  6. Rebooting the device.

Still no luck. each time, the app icon would glow when i tapped it, the app would appear in my recent apps list as a black rectangle, but no matter how long I left it (several hours at one point), it just wouldn't load.

In desperation, I restored the app's Titanium backup with data, and it (sort of) worked. The app loaded, and allowed me to log in again (as if I'd just done a fresh install, or restored the app without data).

The weird thing is that the app has not been updated since I made the backup, so the backup version is the same as the version on the Play Store.

Does anyone know why restoring the Titanium backup would work where the troubleshooting steps I took above didn't? Is it possible that the app's data got given some weird permissions at some point that only Titanium, running as root, could sort out?

Thank you in advance!
Last edited by FluidDruid; 8th September 2014 at 11:18 AM. Reason: Typo - spelling
 
 
9th September 2014, 03:46 AM |#2  
Dark3n's Avatar
Recognized Developer
Thanks Meter: 3,394
 
More
Looking at the logcat might offer some insights into why it was not launching.

An educated guess would be that TiBu restored/overwrote a file that the other apps/system did not find and wipe and the app itself corrupts a file when launching and only restoring a working one from your backup fixed it.

If you find out what file that is, SD Maid could be updated to cover that and if it's reproduceable, you could also write the dev of the app instruction how to reproduce the issue so he can fix it.

Of course there is always the option that the server/connection was bad and it hang because of that.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes