Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Bricked glass please help...

OP alexanderb522

1st July 2014, 10:45 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Hi everyone,

Thank you for your time in reading this. I need help with my bricked google glass. Basically I bought a glass not directly from Google 3 weeks ago. Last night I hit factory restore and it shutdown. When it rebooted it just had a white screen displayed. I understand this as the white screen of death after much googling. As I did not get it directly from Google, I do not have support and they will not honor my warranty.

As such I have been trying all sorts of things to restore it to factory and get it to boot up:

I am doing all the activities in OSX.

1. I am able to access fastboot, fastboot devices shows my device serial, however adb devices does not and adb reboot-bootloader cannot find the device.

2. I was able to fastboot oem unlock using ubuntu as there is a known issue running this in osx. All other subsequent activities were done in osx.

3. I was able to download the factory image from the google developer site. I downloaded XE18.11 and XE18.1 as I remember the device updated to XE18.1 OTA.

4. I put the device into recovery mode by holding the picture button, pressing the power button and continue holding the picture button for 10-15 seconds.

5. When in fastboot/recovery mode, fastboot devices works, fastboot reboot-bootloader works but adb reboot-bootloader does not - it does not find the device, neither does adb devices.

6. I can fastboot flash boot boot.img but the next step hangs when I execute fastboot flash system system.img. It just hangs and does nothing. Manually triggering fastboot flash recovery recovery.img works, it's just the system.img that hangs...

However, if I fastboot -w flashall, it is able to send and write the boot, system and recovery images to the device but it still boots to a white screen after. I was expecting it to work and be restored to factory as the image files were successfully written.

The factory image for XE18.11 and XE18.1 contain the files below:

android-info.txt
boot.img
bootloader.img
fpga.img
recovery.img
system.img
userdata.img
xloader.img


7. fastboot flashall only flashes boot, system and recovery. Do I need to manually flash bootloader.img? What is the danger of doing this? I am afraid of touching the bootloader as this is the only thing letting me connect to the device.

8. What about the other image files like xloader.img, userdata.img, fpga.img...do I need to manually flash those as well?

I would appreciate any help from you experts to help me bring this back to life. I can't afford to have a very expensive brick.

If anyone can help me fix this, I am willing to donate to a charity of your choice whatever I can afford.

I am desperate and willing to try anything...

Thank you everyone!



Apologies to the mods, if this should be in the glass forum, I did not find any technical/help section there so I decided to post it here.


Alex
2nd July 2014, 10:44 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Any experts out there who can help me please?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes