Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,836 Members 41,419 Now Online
XDA Developers Android and Mobile Development Forum

[Q] New Chinese smartphone has me stuck at lockscreen

Tip us?
 
Fallingwater
Old
#1  
Member - OP
Thanks Meter 3
Posts: 40
Join Date: Jan 2012
Default [Q] New Chinese smartphone has me stuck at lockscreen

I bought a Chinese smartphone from DX.com. I wasn't expecting great quality, but I was expecting it to at least give me a workable system out of the box. Instead, upon first powerup it gives me a lock screen - and I'm not told what the lock key is. I requested help on DX's forum, but as they don't themselves manufacture it I expect the answer to take a long time to arrive, if it ever does.

By powering it up with various buttons pressed I've managed to get it to boot to what I'm assuming is some kind of debug/recovery menu. It's interesting that it isn't the usual Android recovery, but it's something running within the system itself.

In this mode the lockscreen is disabled, but so is most of the operating system. I did manage to get to the settings/language menu, but when I access it I get this error.

I tried accessing the developer options in the hope of enabling debugging and accessing the filesystem via ADB, but the whole submenu is inaccessible in this weird testing mode.

As for the obvious idea - accessing the security menu and disabling the lockscreen - even in this mode it still wants the previous combination before it'll let me disable it.

The debug menu itself. I tried accessing a few options at random, but I get a lot of text I can't understand and large buttons with red/green colouring that look menacing. What little is written in Latin alphabet (stuff like RECALIBRATION) makes me think I could easily screw the phone up by experimenting with the various options without knowing what I'm actually doing. In general it seems like a hardware test app, though; one of the options I did dare test makes colors appear if you push the non-touchscreen buttons. I'm not sure anything in this can be used to bypass anything.

I tried posting to the /r/chinese subreddit to see if they can make sense of those menus. Is there anything I can do in the meantime? I don't know, does Android 4.3.3 have a default combination for that accursed lock screen? Getting to the default Android recovery and doing a factory wipe would probably solve the problem, but so far I've only managed to get the weird testing mode by booting with buttons pressed.
 
Fallingwater
Old
(Last edited by Fallingwater; 8th July 2014 at 02:28 PM.)
#2  
Member - OP
Thanks Meter 3
Posts: 40
Join Date: Jan 2012
After an immense driver headache, I have managed to gain ADB access to the filesystem. However, "adb reboot recovery" doesn't show a recovery menu - I get the Android animation with the rotating whatsitsname, then a red exclamation mark.

Edit: I have changed the language to English via ADB. The lockscreen is still stubbornly in place.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes