FORUMS
Post Reply Subscribe to Thread Email Thread

[Q] coolpad 7236, problems

20th August 2014, 07:53 AM |#1  
OP Member
Thanks Meter: 11
 
More
hello, hope i post it in the right place, if not, please move it.

i bought the phone coolpad 7236, based on snapdragon 200 msm8212 chip.
i found out that i got the chinese version of the firmware, so the seller gave me a link for the multi language firmware: http://www.mediafire.com/folder/7g49...r_Coolpad_7236

there are some files there, offical flashtool, quallcom flash files (to be used with the flashtool), drivers, and an archive containg a script that should replace the entire system folder via adb.
i translated the .cmd file and here it is:
Quote:

@echo off
%~d0
CD "%~d0%~p0"

set id=7236

taskkill /F /IM tadb.exe >nul 2>nul
taskkill /F /IM bdadb.exe >nul 2>nul
taskkill /F /IM sjk_daemon.exe >nul 2>nul
taskkill /F /IM romaster_daemon.exe >nul 2>nul
taskkill /F /IM AndroidInterface.exe >nul 2>nul
taskkill /F /IM adb.exe >nul 2>nul

adb.exe kill-server >nul 2>nul
echo .
echo The ROM for models%id%
echo .
echo Flash this ROM, please brush into the bottom of the package custom 7236
echo.
echo Brushing the bottom package, the phone is switched, the screen splash screen again after connecting USB
echo.
echo Note: During the brush machine, the phone screen is blank, do not operate the phone buttons until the phone automatically restart
echo.
title %id% ʰ By Kyle
pause
:flash
color 1B
cls
adb -d push boot.img /tmp/.
echo Begin transmission system file, about 300M, wait. . . .
adb -d push system7236.tar.gz /tmp/.
adb -d shell mount /data
adb -d shell mount /system
adb -d shell rm -r /system/*
adb -d shell rm -r /data/*
adb -d shell tar -zxvf /tmp/system7236.tar.gz -C /
adb -d shell dd if=/tmp/boot.img of=/dev/block/platform/msm_sdcc.1/by-name/boot
adb -d shell reboot
echo Finished, the phone will automatically enter recovery, the recovery interface, you can directly select reboot system now
pause
exit

as you can see, it deletes the system folder and should put the contents of the archive as new system folder.
unfortunally this only made the first step, as soon as the script deleted the system folder, the phone stopped working.
i tried using adb shell to do it manually, but it didn't complied to simple commands as "dir" "ls" "cp" "pull" "push", the phone became a brick.

then i tried using the flashtool, the company says that in order to use it you should dial
Quote:

#*20110606#

and then choose test mode or something in order to allow the flashtool put it in download mode, obiously i can't do that now. i figured that when i hold the power button the screen turns white, making the phone discoverable as quallcom hs-usb diagnostics or something like this, it doesn't work with the flashtool (it searches for qdloader device).

then i tried dumping system.img from other coolpad 7236 device, i used this tutorial: http://forum.xda-developers.com/show....php?t=2450045 and i got 800MB file, the fastboot refused to get it, then i used this fastboot: http://forum.xda-developers.com/moto...tboot-t2493814

waited for 30 minutes, but it was stuck on sending.

also, i couldn't get the fastboot to work, i tried to flash the boot.img that the seller gave me in the link, but the fastboot got stuck in "writing", the fastboot also ignored simple commands such as reboot.

the stocvk recovery is not helping either because i don't have signed update.zip for it.

is there anything else to do beside sending it back to china?
and, is there any GOOD WAY to replace the contents of the system folder (in case i get another chinese like this) without bricking the phone?
 
 
25th August 2014, 06:35 AM |#2  
OP Member
Thanks Meter: 11
 
More
Figured it out, nevermind
19th January 2015, 04:17 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by kkffiirr

Figured it out, nevermind

Hi,
I'm new to all this. And I am having a Coolpad 7236 currently. It is also in Chinese and I do not know how to read that....Sigh...
Good phone with some flaws.
I'm interested in rooting it and flushing out the software to install a new one but I do not know how.
Can help?
Thanks
19th January 2015, 05:07 AM |#4  
OP Member
Thanks Meter: 11
 
More
iandroid.co.il/forum/viewtopic.php?f=190&t=179082&hilit=7236
Use Google translate
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes