Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

difficulty installing botbrew basil experimental (maybe related to /var)

OP gardina

3rd September 2014, 04:54 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Aug 2014
hi, I downloaded botbrew, supersu granted it super access. It says something like "extract archive: cannot create symlink from ./system/bin/botbrew to /data/botbrew/bin/borbrew read-only file system.."

To reinstall I tried choose uninstall in the play store, and on phone, then install but it just starts back up without reinstalling. So didn't really uninstall. And also I can't see any terminal with it. I went into android terminal but it can't see any command like apt-get I see about adding a repository and searching for packages.. what repository to add to use ssh and nmap and get apt-get? (i'd like to do apt-get install dropbear)

I don't recall if that was when trying botbrew root or botbrew basil.

I have gone to the android terminal and run 'botbrew' , I see the $PATH variable change to include botbrew/bin so I know i'm in. but I don't have apt-get (which I want)

I had installed botbrew root beforehand, then realised it didn't have apt-get, so I went for botbrew basil experimental.

Botbrew basil experimental is showing nothing in the 'installed' tab, At one point one tab said something like dpkg or something was pending, but something was locked and it couldn't continue with that. So I closed some other programs and turned my phone off and on, and went back into Botbrew but now I see nothing pending.

I just got this message
E: Couldn't create temporary file to work with /var/lib/apt/lists/repo.botbrew.com_basil_main_Release - mkstemp (13: Permission denied)
E: The package lists or status file could not be parsed or opened
E: No packages found

I suppose perhaps that message might be from apt-get.. operating within the botbrew gui..

It's not surprising that it can't write to /var , as there is no /var directory on my phone. I tried cd /var, also as root.. from a terminal but nope, that directory doesn't exist.

I considered posting to http://forum.xda-developers.com/show...&postcount=119 as that looks like it might be a dedicated thread. I don't know if i'm too newby to post in that section, but anyhow I can't in that section as one needs 10 posts to.

TIA
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes