[Q] Help required. Cant Root MTK6589 chinese device after failed partition resize.

24 posts
Thanks Meter: 1
By HNaseer, Junior Member on 4th September 2014, 08:42 AM
Post Reply Subscribe to Thread Email Thread
Hello All,

First the device specs.

Device: QMobile A900 MTK6589 dual sim chinese device.
OS: LG G3 Kitkat 4.4.2 rom.

Now the Problem

I am also facing this problem after attempting to re-size the partition using meteos mtk6589 rom edit apk and then did clear eMMC / Factory Reset using stock recovery (i think it formatted /data partition etc) .... Although my phone is still working properly without any issue, i am unable to root or install CWM by any means (tried mtk mobileuncle tools, tried spflash tool) but not working.

First, i tried to root using RootMaster vRoot, motochopper run.bat but failed. It did however installed SuperSU but when i start it says binary needs to be updated. I continue but it fails to update. I used RootChecker app to check the possible root but it says device is not rooted. I searched xda-forums and googled for a solution but couldnt find any. One person stated using Format whole flash to reset the partition table but i haven't done that worrying my phone will brick.

Secondly, i tried flashing cwm recovery using spflash tool (with new scatter file generated with MTKDroidTools). After flashing, it says All OK and shows green circle, however, when i reboot in to recovery, i get stock recovery and no CMW.

Please help me how to root my device and install cwm as i am unable to revert to my old backup taken with cwmr.

4th September 2014, 09:43 AM |#2  
OP Junior Member
Thanks Meter: 1
Please some one ???
4th September 2014, 04:42 PM |#3  
OP Junior Member
Thanks Meter: 1
Anybody care to help pl? :banghead:
9th September 2014, 09:26 PM |#4  
OP Junior Member
Thanks Meter: 1
Still waiting for xda experts replies ....
28th January 2015, 03:48 PM |#5  
Senior Member
Thanks Meter: 14
Have a look at this thread to enhance the app storage to an acceptable limit in A900. I was also thinking of Meteos App first , then tried the procedure in the link below :

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes