FORUMS

Honor 7 Google Play Services Severe Problems

1 posts
Thanks Meter: 0
 
By Max Memory, Junior Member on 22nd July 2015, 11:50 PM
Post Reply Subscribe to Thread Email Thread
Hope this is an appropriate place to post this :

I was very keen on the Honor 7 due to 64gb memory, sd card, octacore processor, battery and price.

I ordered one from China, and have had it for 2 days. However, am having severe problems.

When adding an account, there is no option for 'Google'.

I have installed Google Play from the Huawei app store and added an account via Play's startup, and for a while, I could download

from Play store and synch gmail and contacts.

I then started to get error "Error while retrieving information from the server RPC:S-7:AEC-0 ..." when trying to download from

the Playstore.

I have tried *many* recommendations including :

*Deleting data and cache from Play app, Play services, and framework services.

*Deleting the account and re-adding.

*Full factory reset and adding Play again from the app store.

*Uninstalling Play service updates so it rolls back to factory version and running Play again to force it to update Play services

to the latest version.

Some of the attempts temporarily resurrect Play, and synching, but now I get "Google play services which some of your

applications rely on is not supported by your device"

Each time I try a fix, the time it runs successfully seems less.

Is it worth me perservering with this : for example is it the need for international firmware on the phone? Could flashing a new

ROM get round this?

Is it because I can't add a Google account. It's weird I managed to download loads of apps, but now can't download any!

Or is it likely to be a phone hardware / firmware / memory unfixable problem?

In every other respect, it's a superb phone and I am reluctant to start the whole returns process if possible, however, if I have

to , I must! (Trouble is, I can't see another phone I want as much : my requirements are maximum processor and memory plus must

support sd card).

Any help much appreciated.
 
 
25th July 2015, 09:49 AM |#2  
Senior Member
Thanks Meter: 135
 
More
My best guess is that you picked up the wrong version of GPS. You have 64bit processor and therefore must select the corresponded GPS. Try this:
Factory reset and enable adb debugging. Go to http://www.needrom.com/?s=honor+7&sa=search&scat=0, choose the correct ROM or upgrade if exist and flash it following the instructions carefully. Do not miss the ROM or instructions otherwise you can brick the phone.
After that flash the correct GPS from http://www.apkmirror.com/apk/google-...-apk-download/ and GP from http://www.androidapksfree.com/apk/g...sion-download/

Flash on your own risk. I'm not familiar with your previous activities and I'm not taking any responsibility. Good luck.
The Following User Says Thank You to piskr For This Useful Post: [ View ]
5th August 2015, 08:45 PM |#3  
Member
Thanks Meter: 5
 
More
I am having exactly same problem with my honor 7. Glad I am not alone, however, I was not able to fix it on my own.
6th August 2015, 10:16 PM |#4  
Member
Thanks Meter: 5
 
More
I actually did almost what piskr proposed: Installed older version of Google Play 5.7.10 or similar and so far it looks good.
Give it a try, apk could be found on the web
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes