Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,293 Members 38,882 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lenovo s920 bricked! HELPPPP!!

Tip us?
 
d_noizeshakerz
Old
#1  
d_noizeshakerz's Avatar
Junior Member - OP
Thanks Meter 3
Posts: 28
Join Date: Feb 2013
Location: Shah Alam, Malaysia
Default [Q] Lenovo s920 bricked! HELPPPP!!

Hi Guys,

First of all, I'm not new to this cust-rom-ing, rooting and flashing stuff as I have done it to many phones before, (OneX,Xperia TX,P780,S3,Note1,Xperia PLay) and much more.

But now, I've encountered an issues with S920. It seems like I've mistakenly flashed a wrong preloader for the phone, and now it refuses to turn on. But my computer, can still detects it.

The real issue is, when I'm trying to flash back the stock rom with SP FLASHTOOL, the flashing starts with red bar shoot up to 100%, then I got an error which says "BROM ERROR : S_T_ENABLE_DRAM_FAIL (4032)"

I have downloaded multiple version of stock ROMs, tried with different version of SP Fashtools, but to no avail. Now I'm completely out of idea of what else I can do.

I have spent few hours searching on the net in regards to the issue but seems like every thing I have tried, failed.

Is anyone have faced similar issue and willing to help, please do. Your help is very much appreciated!

Thank you guys! Excuse me my English.
Make. Believe.
 
Hell_X
Old
#2  
Hell_X's Avatar
Senior Member
Thanks Meter 33
Posts: 154
Join Date: Nov 2012
Location: Android :D

 
DONATE TO ME
Quote:
Originally Posted by d_noizeshakerz View Post
Hi Guys,

First of all, I'm not new to this cust-rom-ing, rooting and flashing stuff as I have done it to many phones before, (OneX,Xperia TX,P780,S3,Note1,Xperia PLay) and much more.

But now, I've encountered an issues with S920. It seems like I've mistakenly flashed a wrong preloader for the phone, and now it refuses to turn on. But my computer, can still detects it.

The real issue is, when I'm trying to flash back the stock rom with SP FLASHTOOL, the flashing starts with red bar shoot up to 100%, then I got an error which says "BROM ERROR : S_T_ENABLE_DRAM_FAIL (4032)"

I have downloaded multiple version of stock ROMs, tried with different version of SP Fashtools, but to no avail. Now I'm completely out of idea of what else I can do.

I have spent few hours searching on the net in regards to the issue but seems like every thing I have tried, failed.

Is anyone have faced similar issue and willing to help, please do. Your help is very much appreciated!

Thank you guys! Excuse me my English.
if you have taken the MTKDRoid tool backup than its simple just select the scatter file and select preloader and flash
My Work:

Quote:
Visit My Small Blog :
www.Qhub.tk
 
d_noizeshakerz
Old
#3  
d_noizeshakerz's Avatar
Junior Member - OP
Thanks Meter 3
Posts: 28
Join Date: Feb 2013
Location: Shah Alam, Malaysia
Yeah mate . That's the precious step I missed. Lol. Flashing has never gone wrong with my P780 with the same chipset and I have flashed my p780 like hundreds of times already. I didn't thought of doing any backup since on the phone I have nothing to back up anyway and never thought that such issues exist. Anyway, the issue has been resolved now. I sent it back to the shop where I bought it and the technician there fixed it for me.

I guest they must be using tools like the Volcano box, etc.

On the same note, I have never use droid tools since I have never face this issue before.

Thanks for replying anyway, appreciated it.

Peace out!
Make. Believe.
 
iZLeeP
Old
#4  
Senior Member
Thanks Meter 106
Posts: 388
Join Date: Jan 2014
Location: Manila
Uninstall all drivers related to the phone including vcom drivers and restart the system. Re-install the drivers again and use SPFT to flash the correct firmware.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes