Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Lenovo s920 bricked! HELPPPP!!

OP d_noizeshakerz

6th July 2014, 12:35 AM   |  #1  
d_noizeshakerz's Avatar
OP Junior Member
Flag Shah Alam, Malaysia
Thanks Meter: 3
 
28 posts
Join Date:Joined: Feb 2013
More
Hi Guys,

First of all, I'm not new to this cust-rom-ing, rooting and flashing stuff as I have done it to many phones before, (OneX,Xperia TX,P780,S3,Note1,Xperia PLay) and much more.

But now, I've encountered an issues with S920. It seems like I've mistakenly flashed a wrong preloader for the phone, and now it refuses to turn on. But my computer, can still detects it.

The real issue is, when I'm trying to flash back the stock rom with SP FLASHTOOL, the flashing starts with red bar shoot up to 100%, then I got an error which says "BROM ERROR : S_T_ENABLE_DRAM_FAIL (4032)"

I have downloaded multiple version of stock ROMs, tried with different version of SP Fashtools, but to no avail. Now I'm completely out of idea of what else I can do.

I have spent few hours searching on the net in regards to the issue but seems like every thing I have tried, failed.

Is anyone have faced similar issue and willing to help, please do. Your help is very much appreciated!

Thank you guys! Excuse me my English.
6th July 2014, 06:41 PM   |  #2  
Hell_X's Avatar
Senior Member
Flag Android :D
Thanks Meter: 38
 
168 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Quote:
Originally Posted by d_noizeshakerz

Hi Guys,

First of all, I'm not new to this cust-rom-ing, rooting and flashing stuff as I have done it to many phones before, (OneX,Xperia TX,P780,S3,Note1,Xperia PLay) and much more.

But now, I've encountered an issues with S920. It seems like I've mistakenly flashed a wrong preloader for the phone, and now it refuses to turn on. But my computer, can still detects it.

The real issue is, when I'm trying to flash back the stock rom with SP FLASHTOOL, the flashing starts with red bar shoot up to 100%, then I got an error which says "BROM ERROR : S_T_ENABLE_DRAM_FAIL (4032)"

I have downloaded multiple version of stock ROMs, tried with different version of SP Fashtools, but to no avail. Now I'm completely out of idea of what else I can do.

I have spent few hours searching on the net in regards to the issue but seems like every thing I have tried, failed.

Is anyone have faced similar issue and willing to help, please do. Your help is very much appreciated!

Thank you guys! Excuse me my English.

if you have taken the MTKDRoid tool backup than its simple just select the scatter file and select preloader and flash
6th July 2014, 06:51 PM   |  #3  
d_noizeshakerz's Avatar
OP Junior Member
Flag Shah Alam, Malaysia
Thanks Meter: 3
 
28 posts
Join Date:Joined: Feb 2013
More
Yeah mate . That's the precious step I missed. Lol. Flashing has never gone wrong with my P780 with the same chipset and I have flashed my p780 like hundreds of times already. I didn't thought of doing any backup since on the phone I have nothing to back up anyway and never thought that such issues exist. Anyway, the issue has been resolved now. I sent it back to the shop where I bought it and the technician there fixed it for me.

I guest they must be using tools like the Volcano box, etc.

On the same note, I have never use droid tools since I have never face this issue before.

Thanks for replying anyway, appreciated it.

Peace out!
7th July 2014, 08:46 AM   |  #4  
Senior Member
Flag Manila
Thanks Meter: 129
 
464 posts
Join Date:Joined: Jan 2014
More
Uninstall all drivers related to the phone including vcom drivers and restart the system. Re-install the drivers again and use SPFT to flash the correct firmware.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes