Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,443 Members 39,214 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Android low performance after sleep for 5 min or more

Tip us?
 
7y2241
Old
(Last edited by 7y2241; 5th July 2014 at 06:55 PM.) Reason: Adding GPU
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Prompt [Q] Android low performance after sleep for 5 min or more

Hello for all!

Sorry my english...

Well, i have a low cost tablet, less of 100 bucks, AOC MID 7y2241. It have Amlogic (mason 6) Dual Processor set in 1.2Ghz and 1 GB RAM, GPU Dual Mali 400, running Jelly Bean 4.1.1

It can run all games in excellet performance if... dont sleep. Take easy, i can explain:

Yeah, i dont know why, but, when tablet turns on, he play everything very well. But, if the screen lock and sleep for 5 min or more, the tablet shows me so much lag and low performance after wake up. Just way to back to good playing is restarting device.

I think the problem is the power saving or a seriuos bug, but i not sure. This tablet is set up in conservative mode, and i cant change it. Really, i cant change nothing relative of CPU. I already rooted device with kongo, it works really good! But any apps of overclock dont works in this device. Give root permission, you set, but nothing happen.

I try change manually sys directory (cpufreq), with adb shell, but is same. I give permissions to rw, but the device return me ALWAYS operation denied.

Well, i like to know if is possible write in sys directory. I try for adb and rooted file explorer, but always is operation failled or denied. If this low performance after sleep is a bug, how to fix or if change the governor can help me in this case?

I cant wait for updates... maybe this tablet never see other android version. I cant change image files and rom, cause i cant do backup in this device. Need a solution for compiled kernel.

Seens it is not a particularity of my device. All AOC MID 7y2241 shows this same problem (but only me realized.). Everyone thinks this tablet is slow, but it can run heavy apps and games easily (before first sleep).

Pls, a really need some help (more than 5 days searching and nothing...)



************************************************** *******
News: When device restart, 2 cores are working. After 5 min sleeping (lock screen), just one core work. Nothing do the second core wake up. Just shows stopped in CPU-Z. I think this is the problem. How i can fix?
 
7y2241
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default For god, nobody????

Cmon guys, just 5 min of a genius can libert me of my insanity!!!
 
Hell_X
Old
#3  
Hell_X's Avatar
Senior Member
Thanks Meter 36
Posts: 154
Join Date: Nov 2012
Location: Android :D

 
DONATE TO ME
Quote:
Originally Posted by 7y2241 View Post
Hello for all!

Sorry my english...

Well, i have a low cost tablet, less of 100 bucks, AOC MID 7y2241. It have Amlogic (mason 6) Dual Processor set in 1.2Ghz and 1 GB RAM, GPU Dual Mali 400, running Jelly Bean 4.1.1

It can run all games in excellet performance if... dont sleep. Take easy, i can explain:

Yeah, i dont know why, but, when tablet turns on, he play everything very well. But, if the screen lock and sleep for 5 min or more, the tablet shows me so much lag and low performance after wake up. Just way to back to good playing is restarting device.

I think the problem is the power saving or a seriuos bug, but i not sure. This tablet is set up in conservative mode, and i cant change it. Really, i cant change nothing relative of CPU. I already rooted device with kongo, it works really good! But any apps of overclock dont works in this device. Give root permission, you set, but nothing happen.

I try change manually sys directory (cpufreq), with adb shell, but is same. I give permissions to rw, but the device return me ALWAYS operation denied.

Well, i like to know if is possible write in sys directory. I try for adb and rooted file explorer, but always is operation failled or denied. If this low performance after sleep is a bug, how to fix or if change the governor can help me in this case?

I cant wait for updates... maybe this tablet never see other android version. I cant change image files and rom, cause i cant do backup in this device. Need a solution for compiled kernel.

Seens it is not a particularity of my device. All AOC MID 7y2241 shows this same problem (but only me realized.). Everyone thinks this tablet is slow, but it can run heavy apps and games easily (before first sleep).

Pls, a really need some help (more than 5 days searching and nothing...)



************************************************** *******
News: When device restart, 2 cores are working. After 5 min sleeping (lock screen), just one core work. Nothing do the second core wake up. Just shows stopped in CPU-Z. I think this is the problem. How i can fix?
uninstall apps you wont use and also
try clearing cache you can do so by finding at play store
My Work:

Quote:
Visit My Small Blog :
www.Qhub.tk
 
7y2241
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default Thanks so much for coop!

Quote:
Originally Posted by Hell_X View Post
uninstall apps you wont use and also
try clearing cache you can do so by finding at play store
************************************************** ********************************************

Man, i really really apreciatte your iniciative. Thank you so much! I dont give up yet...


I already do a factory reset, cleanning cache, using Power + Up Button. And not work... Maybe you want said other thing, maybe?


I pass last days broken head in this S.O, and seens a bugged kernel. The tablet boot, and 2 cores working. When 5 min pass by (standby), the cpu 1 is setted off line, and dont wake up again until restart. In I9100, the core wake up frequently, according to demand. But in this case, it dont wake anymore...

When the tablet boot, In "cpu1" folder (in sys/devices/system/cpu/), there is a shortcut of folder "cpufreq" contained in "cpu0" folder. When pass 5 min in standby, the cpu1 is setted like offline, and this shortcut (cpufreq folder in cpu0) is deleted, together with folder "topology". When force wakeup cpu1, just folder "topology" backs. In short, the shortcut of "cpufreq" folder in "cpu1" folder no back anymore.

I think that cpu1 stays without freq control, cause system tuner apps shows the cpu1 like online (just when force wake up), but without freq, just shows n/a.

I really really apreciate a solution for this problem. No one apps can do anything usefull.

For hour, this table have a 4000mah battery, so, i dont matter if i can disable hotplug cpu function. I prefer let 2 cores working that let it cpu1 in offline.

All apps that give tweak "all core enable" in boot dont work (rooted). I need a way that prevent the cpu1 to be setted offline permanently when in standby (lock screen), to avoid first offline set in cpu1.
 
iZLeeP
Old
#5  
Senior Member
Thanks Meter 106
Posts: 395
Join Date: Jan 2014
Location: Manila
Something to do with your cpu governor not scaling properly on wake up. Download No-frills CPU Control from playstore. You can read about this app in here.

Try setting the cpu governor to interactive (if none, ondemand) and i/o scheduler to sio (if none, noop or deadline). You can also adjust the min/max frequencies of the stock values.
 
7y2241
Old
(Last edited by 7y2241; 7th July 2014 at 05:52 PM.)
#6  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default Yet trying!

Hello!!!

Thanks god, somebody reply me!

So, how i said, noone apps in google play works (rooted) in this tablet. The No Frills was the first that i try. I click apply, but the config dont change (rooted!).

Is a total root. No this problem. I think that cpu Amlogic have some limitations. Maybe the energy controller is very limited, cause i cant change freqs, governors and I/O (any apps). Just have "conservative" (default, i cant change) and "performance2" (i cant set) governors. Exists "performance", but not have config options (is like no exists).

Or, maybe, the kernel of this android version no able this changes (in this case, i have hope).

I think I/O dont go work here (disk scheduler). What i want is prevent cpu1 set offline, maybe disabling hotplug control?

I discover that this cpu set auto offline cpu1 after 40 ~ 50 min playing heavy games (for sure, high temps...). Certainly, the power manager of cpu Amlogic meson6 is very useless.

If somebody know how disable it in kernel options (maybe uninstalling drivers?), it would be amazing
 
7y2241
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default Reviving topic...

Reviving topic...
 
7y2241
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default Reviving topico again...

Reviving topic again...
 
Hell_X
Old
#9  
Hell_X's Avatar
Senior Member
Thanks Meter 36
Posts: 154
Join Date: Nov 2012
Location: Android :D

 
DONATE TO ME
Quote:
Originally Posted by 7y2241 View Post
Reviving topic again...
Claim warranty!
My Work:

Quote:
Visit My Small Blog :
www.Qhub.tk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes