Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Play store not working on WiFi but works on cellular, problem

OP agazza

30th July 2014, 07:45 AM   |  #1  
OP Senior Member
Thanks Meter: 13
 
250 posts
Join Date:Joined: Nov 2011
Hello I got a problem yesterday.

My play store won't logg in when I'm connected to a WiFi. But it works on the cellular connection.

I tried the following that I found online.

Wiping data, etc from the app.
Disabling it and restarting the app.
Same and restarting phone.
Changing the date and time
Changing it back to auto
Forgetting the WiFi and adding it again
I tried modifying he hosts file
Flash the gapps all over again.

Nothing helps, and I think some other Google services isn't working properly either.

I tried disabling juicedefender and adblock plus, the only two things I suspected, but nothing.

Any ideas? This is crippling my phone [emoji53]

Sent from my one+
30th July 2014, 09:33 PM   |  #2  
OP Senior Member
Thanks Meter: 13
 
250 posts
Join Date:Joined: Nov 2011
Okey, this is what you need to do if you get the playstore problem. With adblock and adaway.

You need to be rooted.

Download hosts editor and add

First row
#74.125.93.113
Second row
android.clients.google.com

Save and reboot.


Search words

Playstore WiFi connection problem

Sent from my one+
30th July 2014, 11:36 PM   |  #3  
Planterz's Avatar
Senior Member
Flag Tucson, AZ
Thanks Meter: 272
 
963 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by agazza

Hello I got a problem yesterday.

My play store won't logg in when I'm connected to a WiFi. But it works on the cellular connection.

I tried the following that I found online.

Wiping data, etc from the app.
Disabling it and restarting the app.
Same and restarting phone.
Changing the date and time
Changing it back to auto
Forgetting the WiFi and adding it again
I tried modifying he hosts file
Flash the gapps all over again.

Nothing helps, and I think some other Google services isn't working properly either.

I tried disabling juicedefender and adblock plus, the only two things I suspected, but nothing.

Any ideas? This is crippling my phone [emoji53]

Sent from my one+

Is this your own wi-fi, or are you using a hotspot provided by a restaurant, supermarket, Kinkos, etc? Hotspots from places like this often require you to "log in". If this is the case, you need to load a browser and try going to a page, and you'll be directed to their own page, where you'll have to accept their terms and conditions in some manner, then you'll be good to go with Play Store and whatever else.
31st July 2014, 07:55 AM   |  #4  
OP Senior Member
Thanks Meter: 13
 
250 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by Planterz

Is this your own wi-fi, or are you using a hotspot provided by a restaurant, supermarket, Kinkos, etc? Hotspots from places like this often require you to "log in". If this is the case, you need to load a browser and try going to a page, and you'll be directed to their own page, where you'll have to accept their terms and conditions in some manner, then you'll be good to go with Play Store and whatever else.

My own, I noticed that it's a common problem after some google-fu

Sent from my one+
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes