Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,000 Members 49,017 Now Online
XDA Developers Android and Mobile Development Forum

S4 clone MTK problem

Tip us?
 
xixorro
Old
(Last edited by xixorro; 1st September 2014 at 03:26 PM.)
#1  
Member - OP
Thanks Meter 1
Posts: 47
Join Date: Apr 2012
Default S4 clone MTK problem

Hi,

I usually read a lot before posting something here but this time I think I am bit overwhelmed . My phone is going for repair to replace it I have this S4 clone. I couldn't install google services because of the shared ID error and that's when I messed up. I kept deleting apps in titanium that I shouldn't and now I face a "little" problem. my google play app opens and immediately closes.

So i figured I should flash some ROM, a thing that I done a lot. Well, not on MTK phones. There are tons of roms for phones that look the same but apparently aren't.

So I need your help.

CPU-z shows my phone as a MTK 6572 and mtk tool as 6589. When I plug it in meda transfer mode it shows 6589 also

I was ready to try and use SP flash but the tutorial said to remove the battery and plug in the phone. But nothing happened.

So If someone can help it would be much appreciated. I can provide every info you need, if I can get to it.

At this point I would be glad just to open google play or add my google account .Oh I forgot to mention that. I don't have the option to add a google account also. I messed up big time

And here I thought I couldn't miss my huawei .

Thanks in advance
[IMG="More info"][/IMG]
 
superdragonpt
Old
#2  
Account currently disabled
Thanks Meter 4,895
Posts: 1,788
Join Date: Apr 2013
Location: Lisbon

 
DONATE TO ME
Quote:
Originally Posted by xixorro View Post
Hi,

I usually read a lot before posting something here but this time I think I am bit overwhelmed . My phone is going for repair to replace it I have this S4 clone. I couldn't install google services because of the shared ID error and that's when I messed up. I kept deleting apps in titanium that I shouldn't and now I face a "little" problem. my google play app opens and immediately closes.

So i figured I should flash some ROM, a thing that I done a lot. Well, not on MTK phones. There are tons of roms for phones that look the same but apparently aren't.

So I need your help.

CPU-z shows my phone as a MTK 6572 and mtk tool as 6589. When I plug it in meda transfer mode it shows 6589 also

I was ready to try and use SP flash but the tutorial said to remove the battery and plug in the phone. But nothing happened.

So If someone can help it would be much appreciated. I can provide every info you need, if I can get to it.

At this point I would be glad just to open google play or add my google account .Oh I forgot to mention that. I don't have the option to add a google account also. I messed up big time

And here I thought I couldn't miss my huawei .

Thanks in advance
Hi

Open cpuz or any other cpu control app and just check how many cpu cores there is.

6572 it's dual-core
6589 it's quad-core

regards
 
xixorro
Old
(Last edited by xixorro; 1st September 2014 at 03:39 PM.)
#3  
Member - OP
Thanks Meter 1
Posts: 47
Join Date: Apr 2012
Quote:
Originally Posted by superdragonpt View Post
Hi

Open cpuz or any other cpu control app and just check how many cpu cores there is.

6572 it's dual-core
6589 it's quad-core

regards
[IMG][/IMG]
[IMG][/IMG]



CPU 3 and 4 seem to remain sopped. What a mess....
 
xixorro
Old
#4  
Member - OP
Thanks Meter 1
Posts: 47
Join Date: Apr 2012
So I have found the right ROM to flash and solve the issue. But not I get the first issue. Cant isntall google play services because od ID error.

Cant seem to find a way to flash custom recovery in order to flash gapps also. Can someone help?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes