Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unresponsive reinstalled Google Play Store app on rooted Samsung SCH-i509

OP VicMan8080

20th July 2014, 10:58 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Device: Samsung SCH-i509
Android Ver: 2.3.6
Rooeted: Yes
Internal Memory: 160MB
Ext memory: 2GB microSD partitioned as: 1st Partition: 1455MB FAT, Second Partition: 515 EXT2 (I am using Link2SD for linking apps to SD card)
Superuser App: SuperSU
Rom Management: RomToolBox lite

I rooted my phone about a fortnight ago, first time rooting, things went fine, and apps were responsive.

2 days back I not only uninstalled the Google Play Store updates but also uninstalled the app, hoping I would install the latest google store APK from Android Police ( Ver: com.android.vending-4.8.22.apk )

I am new to rooting and installing apks, so after installing the above mentioned Google Play Store apk to the SD card and finding it was not responsive (I was getting a blank screen and an error message shortly thereafter which disappeared instantaneously for me to note what it said). I googled and found on a forum, (sorry don't recall which one) that the APK needs to be copied to the system/app folder and any previous apk of Google Play Store needs to be replaced. So using Root Browser in ROMToolBox I copied the apk to system/app.

Doing so did open the 'first run' of Google Play Store, as in I was prompted to allow permission via google account and opened the interface with my apps etc normally. But trouble started when I tried to update the apps. The moment I do that, I get the downloading bar AND then I get the force close screen. The same would happen in the case if I try to download any apps.

I froze the Google Play Store app through ROMToolBox App Manager.

On doing a search on XDA forums before I posted here I came across: http://forum.xda-developers.com/show....php?t=2129881
And did as suggested in this thread: went to the system/app folder through Root Browser and set permission to rw-r--r-- as suggested there.

UNFORTUNATELY things are the same as before: once the app fires up either by clicking on a Google Play Store linked ad or by just opening it, I am back to force close screen.

I would be really thankful if someone could help me out on this.
Also, I am not quite sure how much it makes a difference I was using Link2SD to link all user apps to SD card (I uninstalled this app as well hoping to install the latest version)
20th July 2014, 11:31 AM   |  #2  
Senior Member
Hawaii
Thanks Meter: 229
 
542 posts
Join Date:Joined: Nov 2010
More
You rebooted after changing the apk permissions, right? Also perhaps try force stopping the plays store, wiping the app data then reboot.
20th July 2014, 12:48 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Thumbs up Thanks
Quote:
Originally Posted by jr67

You rebooted after changing the apk permissions, right? Also perhaps try force stopping the plays store, wiping the app data then reboot.

Thanks for the reply. I had rebooted and clear app data but the app was still unresponsive/

The issue resolved when I downloaded an older version of the Google Play Store app and installed it in the sys/app folder after removing the previous one, reconfigured the permissions and rebooted. things are working fine now.

Cheers, have a great weekend!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes