Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,684 Members 48,102 Now Online
XDA Developers Android and Mobile Development Forum

xperia z2 red led not working

Tip us?
 
haroon_3d
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2009
Location xperia z2 red led not working

Hi

I purchased my Z2 just two weeks ago. Yesterday, I went to the beach and used the phone underwater. I went back home and connected the phone to the charger and jacked the headset at the same time. I notice that the red led was flickering as if there is some thing wrong I disconnected the charger an realized that there wast some water inside the headset jack. after that, I was sure the was no drop of water inside the jack and connected the charger again and every thing went- the led began red then orange and finally green at full charge.

Today, I connected the charger when the battery was bellow 7 and the led continued to be green ahead.

PLEAAASE HELP ME PEOPLE
 
TechnoSparks
Old
#2  
TechnoSparks's Avatar
Senior Member
Thanks Meter 57
Posts: 223
Join Date: Mar 2014
Location: Selangor

 
DONATE TO ME
Quote:
Originally Posted by haroon_3d View Post
Hi

I purchased my Z2 just two weeks ago. Yesterday, I went to the beach and used the phone underwater. I went back home and connected the phone to the charger and jacked the headset at the same time. I notice that the red led was flickering as if there is some thing wrong I disconnected the charger an realized that there wast some water inside the headset jack. after that, I was sure the was no drop of water inside the jack and connected the charger again and every thing went- the led began red then orange and finally green at full charge.

Today, I connected the charger when the battery was bellow 7 and the led continued to be green ahead.

PLEAAASE HELP ME PEOPLE
Your z2 might be water-damaged.
If you are brave enough, try to go to the service centre and classify your case as factory defect. Tell them that you have followed all possible guidelines before using your phone underwater. Design defect might have caused some water to get inside and damage some essential parts

However, due to not everything are water proof, immersing any phones underwater in a long period of time will of course do some damage. If you indeed used the phone underwater for an extended period of time, this will definitely cause you this problem.
My hobby? I roam the internet!
Please understand that english is not my main language. Excuse my english if there are mistakes

Xperia SP C5303 | Official Cyanogen Mod 11 M10 Snapshot
- Rear mic fix on CM11 (pre 0829) for XSP works on some other ROMs too
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes