Battery Charged in 30 Seconds? Maybe in 2016

Phones and tablets are getting more and more power hungry with each passing generation. Their … more

ZArchive Manages Your File Archives

Today smartphones are quite powerful devices that can handle multiple processes at once. In fact, some of … more

Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[FIX OR TRICK] [ Link2SD ] [NO QUICK REBOOT] How to mount external partition at boot

OP Rockstar.garvit

26th November 2013, 11:23 PM   |  #1  
Rockstar.garvit's Avatar
OP Member
Thanks Meter: 16
 
97 posts
Join Date:Joined: Jan 2012
More
Its a problem for some link2sd users that after a hard reboot (i.e. a full reboot , they get a dialog box saying
"external partition not mounted at the boot time "
And have options to Recreate mount script or Quick Reboot .
This solves the problem ;D.

So what you have to do is:
1. Install mount2sd by from playstore.
2. Now that you have installed , open it
3. Go to settings .
4. Install script (you will find it right on top).
5. Try hard reboot your phone and Bang !! It worked !



If it didn't , make sure that the ROM you are using have init.d support.
You can check it out if your ROM supports it or not by
1. Open root explorer
2. Go to /etc
3. Search for init.d folder.

If it is there, your ROM has this feature to run scripts at the first flash of your phones manufacturer's logo during boot.
If not, try to find patch for it or contact your ROM manufacturer.

If you have the init.d thing and it didn't worked out :+
->Try reinstall link2sd or just recreate mount script.

You can also try out mount2sd itself , its cool
http://forum.xda-developers.com/show....php?t=2432479

I would like to tell you that this is just a trick. That means it worked for me on my galaxy fit with any custom ROM but I am not sure it will work for you and your phone too. And I also do not know how it worked but it works
So don't ask me but the respective owners of their apps, the questions you have .Sorry

DEVS , CORRECT ME IF I AM WRONG
Last edited by Rockstar.garvit; 26th November 2013 at 11:50 PM.
The Following 3 Users Say Thank You to Rockstar.garvit For This Useful Post: [ View ]
26th November 2013, 11:34 PM   |  #2  
Rockstar.garvit's Avatar
OP Member
Thanks Meter: 16
 
97 posts
Join Date:Joined: Jan 2012
More
And after this if you want to remove mount2sd , you can . uninstall it. But I recommend that you should just delete the mount2sd apk from /data/apps using Root Explorer .

And yes, mount2sd needs root permission too. Grant it.
The Following 2 Users Say Thank You to Rockstar.garvit For This Useful Post: [ View ]
6th November 2014, 07:35 AM   |  #3  
Member
Flag Bhavnagar
Thanks Meter: 13
 
57 posts
Join Date:Joined: Jan 2014
More
Unresponsive after mount2sd
Micromax A50, MTK-6573, Unlocked bootloader, android 2.3.6, Rooted, busybox, init.d, adb insecure, link2sd -had that problem of quit re-boot
Tried mount2sd and installed script at start up
Now my device can start but after that it is unresponsive at home screen...nothing is working
Pls help...
Advance thanks...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes