Post Reply

[TOOL] [ANDROID] [4.3/4.4] Verizon MMS APN Patch + Alternatives

3rd August 2014, 10:08 AM   |  #31  
ThePhantom97's Avatar
Senior Member
Flag Robinson
Thanks Meter: 115
 
307 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Just to report back with an update. I am currently able to send and receive MMS messages at this point. I uninstalled sliding messages app that apparently had the ability to changed my APN settings through the app or was not looking in the correct location for the APNs. After uninstalling I was not able to send and receive via stock mms so I flashed the slim_apns again and installed hello sms and through this app I have sent and received 3-4 MMS messages so I really hope this may have cured my issues. Will report back if anything changes.
The Following 2 Users Say Thank You to ThePhantom97 For This Useful Post: [ View ]
3rd August 2014, 06:26 PM   |  #32  
gohamstergo's Avatar
Senior Member
Thanks Meter: 253
 
1,017 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by ThePhantom97

Just to report back with an update. I am currently able to send and receive MMS messages at this point. I uninstalled sliding messages app that apparently had the ability to changed my APN settings through the app or was not looking in the correct location for the APNs. After uninstalling I was not able to send and receive via stock mms so I flashed the slim_apns again and installed hello sms and through this app I have sent and received 3-4 MMS messages so I really hope this may have cured my issues. Will report back if anything changes.

Great news for you and the Slim APNs! :P
The Following User Says Thank You to gohamstergo For This Useful Post: [ View ]
5th August 2014, 11:48 AM   |  #33  
ThePhantom97's Avatar
Senior Member
Flag Robinson
Thanks Meter: 115
 
307 posts
Join Date:Joined: Aug 2012
Donate to Me
More
I must be losing my fn mind. Now I can receive mms messages, however my sent pics are hit and miss whether they get delivered. I have tried small images, large images, camera images and part of the time they go through. I tried with wifi on and off and now I am so confused as to what the actual problem is that I am ready to clean install and start from scratch. Poo, does the vzw_apn_patch.zip automatically save the apn.text file that put my number into the zip file when you sh patch.sh because I am a little confused if I run the sh patch.sh in terminal, why do I need to flash it in recovery? Trust me I am not trying to doubt your expertise, just curious as to how that patch works because I may start with that one if I clean install LS again.
5th August 2014, 02:10 PM   |  #34  
poo706's Avatar
OP Senior Member
Thanks Meter: 1,378
 
1,710 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by ThePhantom97

I must be losing my fn mind. Now I can receive mms messages, however my sent pics are hit and miss whether they get delivered. I have tried small images, large images, camera images and part of the time they go through. I tried with wifi on and off and now I am so confused as to what the actual problem is that I am ready to clean install and start from scratch. Poo, does the vzw_apn_patch.zip automatically save the apn.text file that put my number into the zip file when you sh patch.sh because I am a little confused if I run the sh patch.sh in terminal, why do I need to flash it in recovery? Trust me I am not trying to doubt your expertise, just curious as to how that patch works because I may start with that one if I clean install LS again.

When the script replaced /system/etc/apns-conf.xml, you had to reboot anyway to apply the changes, so I figured a quick reboot to recovery instead wouldn't be a big deal. This method is just safer in case something unexpected happens.

[poo]
6th August 2014, 12:37 AM   |  #35  
ThePhantom97's Avatar
Senior Member
Flag Robinson
Thanks Meter: 115
 
307 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by poo706

When the script replaced /system/etc/apns-conf.xml, you had to reboot anyway to apply the changes, so I figured a quick reboot to recovery instead wouldn't be a big deal. This method is just safer in case something unexpected happens.

[poo]

K, it is not a big deal at all, just wasn't sure if it was a clean up script after running the sh, or if it was actually pushing the apn.text to the location.

Update: Got really frustrated with not being able to send and receive mms so I did a clean install of LS this morning. I stopped the automatic downloads of my apps so I could choose which apps I wanted to install. After changing runtime to ART, flashing kernel and cosmetic tweaks I was able to send and receive mms with consistency for the last approx.12 hours. I didn't have to flash any of the above tweaks. This is with the stock mms which I hate because I absolutely hate a white BG. Will probably try to install another mms app and report back if I find something else screwy going on.
Last edited by ThePhantom97; 6th August 2014 at 12:39 AM.
6th August 2014, 12:51 AM   |  #36  
poo706's Avatar
OP Senior Member
Thanks Meter: 1,378
 
1,710 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by ThePhantom97

K, it is not a big deal at all, just wasn't sure if it was a clean up script after running the sh, or if it was actually pushing the apn.text to the location.

Update: Got really frustrated with not being able to send and receive mms so I did a clean install of LS this morning. I stopped the automatic downloads of my apps so I could choose which apps I wanted to install. After changing runtime to ART, flashing kernel and cosmetic tweaks I was able to send and receive mms with consistency for the last approx.12 hours. I didn't have to flash any of the above tweaks. This is with the stock mms which I hate because I absolutely hate a white BG. Will probably try to install another mms app and report back if I find something else screwy going on.

Would that be my 8/4 unofficial build that you clean installed?

[poo]
6th August 2014, 12:54 AM   |  #37  
ThePhantom97's Avatar
Senior Member
Flag Robinson
Thanks Meter: 115
 
307 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by poo706

Would that be my 8/4 unofficial build that you clean installed?

[poo]

Have not downloaded it yet, just seen that it was up...lol. I used the Official 7/25 build that I still had on my sdcard and that is the crazy part!!!

---------- Post added at 06:54 PM ---------- Previous post was at 06:52 PM ----------

I am going to say that it had something to do with Sliding SMS, because it asks you to select a carrier after install and I believe it changes the APN's automatically. That is the only thing I can trace it back to.
6th August 2014, 01:16 AM   |  #38  
poo706's Avatar
OP Senior Member
Thanks Meter: 1,378
 
1,710 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by ThePhantom97

Have not downloaded it yet, just seen that it was up...lol. I used the Official 7/25 build that I still had on my sdcard and that is the crazy part!!!

---------- Post added at 06:54 PM ---------- Previous post was at 06:52 PM ----------

I am going to say that it had something to do with Sliding SMS, because it asks you to select a carrier after install and I believe it changes the APN's automatically. That is the only thing I can trace it back to.

I use sliding sms too, but I don't remember anything about picking a carrier. Either it's a Verizon thing and not a sprint thing, or I've had too many beers since I installed that and I just don't remember.

[poo]

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android Software Development by ThreadRank