Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,571 Members 54,986 Now Online
XDA Developers Android and Mobile Development Forum

[Bug] Laggy Subtitle Animation

Tip us?
 
ChronoReverse
Old
#1  
Senior Member - OP
Thanks Meter 158
Posts: 1,031
Join Date: Jun 2010
Default [Bug] Laggy Subtitle Animation

I'm curious if I've made a configuration error somewhere.

My GS4 is able to playback 10bit 720p smoothly but for some reason, animated subtitles (think karaoke) play at something like 5FPS. Is there a switch somewhere I missed that can fix this? I've already tried toggling Hardware Rendering for subtitles.
 
CDB-Man
Old
#2  
CDB-Man's Avatar
Senior Member
Thanks Meter 44
Posts: 224
Join Date: May 2013
It's not just you, and it's not device specific. This is a known issue of MX Player. The developer is aware that .ass/ssa subtitle rendering speed isn't optimal. However, MX still has one of the best ass/ssa renderers out there when it comes to ability to render complex styling (the other good subtitle renderer is XBMC for android).

The issue's already on my list that's pinned at the top of the forum.

Quote:
Originally Posted by CDB-Man View Post
Feature Requests
...
EDIT: I assume you already have it set to use 4 cores to decode?
Be sure to hit Thanks when someone helps you out!

MX Player sub-forum Moderator; Primary User Support: http://forum.xda-developers.com/apps/mx-player

The Developer/Owner of MX Player is bleu8888. Please post a thread in the MX Player sub-forum for support.

I do not answer MX Player questions in PM. Post a thread in the MX Player sub-forum if you need support.

The Following User Says Thank You to CDB-Man For This Useful Post: [ Click to Expand ]
 
ChronoReverse
Old
#3  
Senior Member - OP
Thanks Meter 158
Posts: 1,031
Join Date: Jun 2010
Thanks for the reply. Yes I've set it to four cores already.

It's not a gamebreaker I guess. Good to know I didn't make a mistake.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes