Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,416 Members 39,275 Now Online
XDA Developers Android and Mobile Development Forum

[Fixed] [Bug] MXPlayer doesn't play video on Android L (Nexus 5)

Tip us?
 
chrone
Old
#11  
chrone's Avatar
Senior Member
Thanks Meter 389
Posts: 1,025
Join Date: May 2012
Location: Surabaya
Quote:
Originally Posted by CDB-Man View Post
Hmm, so on Android L, the system media volume was mute, but the MX audio still played through? Weird... @bleu8888 any thoughts?
Yeap, it reset the audio to its default level. I could send you a logcat, direct message me where to send though.

Sent from my Nexus 5
LGE Nexus 5 16GB Black: Android KitKat.
efrant's Android 101 for Nexus 4
 
bleu8888
Old
#12  
Senior Member
Thanks Meter 137
Posts: 200
Join Date: Mar 2011
Quote:
Originally Posted by chrone View Post
Yeap, it reset the audio to its default level. I could send you a logcat, direct message me where to send though.

Sent from my Nexus 5
There was a minor bug, please check new test build.
https://sites.google.com/site/mxvpen...ion/test-build
MX Player Developer
The Following 2 Users Say Thank You to bleu8888 For This Useful Post: [ Click to Expand ]
 
chrone
Old
(Last edited by chrone; 16th July 2014 at 07:18 PM.) Reason: attaching screenshot
#13  
chrone's Avatar
Senior Member
Thanks Meter 389
Posts: 1,025
Join Date: May 2012
Location: Surabaya
Quote:
Originally Posted by bleu8888 View Post
There was a minor bug, please check new test build.
https://sites.google.com/site/mxvpen...ion/test-build
Just tested this out with no luck. Audio was still passed through the speaker though system sound was disabled as shown on the status bar - vibrate only.

Perhaps there's a bug on the L preview and not MX Player?

Sent from my Nexus 5
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-07-17-01-09-35.jpg
Views:	30
Size:	115.6 KB
ID:	2855068  
LGE Nexus 5 16GB Black: Android KitKat.
efrant's Android 101 for Nexus 4
 
ktsamy
Old
#14  
ktsamy's Avatar
Senior Member
Thanks Meter 1,479
Posts: 450
Join Date: Sep 2011
Location: Palani / Surat

 
DONATE TO ME
Quote:
Originally Posted by chrone View Post
Just tested this out with no luck. Audio was still passed through the speaker though system sound was disabled as shown on the status bar - vibrate only.

Perhaps there's a bug on the L preview and not MX Player?

Sent from my Nexus 5
I think you have totally misunderstood. Android have individual volume controls for different activities. In my knowledge almost all android systems, If you set on mute/vibrate, it will basically mute only all alert tones like System, Notification, Alarm & Ring Volumes. It does not mute media volume. There is no such native global volume control that can block media volume. There are some custom roms like cyanogen mod which can block volume volume keys. But, that will not also work with media volume.

So, It's not a MX Player bug. It's a lack of android feature.

Look at the volume control settings screenshot which is taken while my mobile is set on mute mode.

Regards,
KTSamy


Hit Thanks if I helped
We are spending our valuable time for you without any cost.
The Following 2 Users Say Thank You to ktsamy For This Useful Post: [ Click to Expand ]
 
chrone
Old
#15  
chrone's Avatar
Senior Member
Thanks Meter 389
Posts: 1,025
Join Date: May 2012
Location: Surabaya
Quote:
Originally Posted by ktsamy View Post
I think you have totally misunderstood. Android have individual volume controls for different activities. In my knowledge almost all android systems, If you set on mute/vibrate, it will basically mute only all alert tones like System, Notification, Alarm & Ring Volumes. It does not mute media volume. There is no such native global volume control that can block media volume. There are some custom roms like cyanogen mod which can block volume volume keys. But, that will not also work with media volume.

So, It's not a MX Player bug. It's a lack of android feature.

Look at the volume control settings screenshot which is taken while my mobile is set on mute mode.

Oh I see, my bad.
LGE Nexus 5 16GB Black: Android KitKat.
efrant's Android 101 for Nexus 4
 
bleu8888
Old
#16  
Senior Member
Thanks Meter 137
Posts: 200
Join Date: Mar 2011
Quote:
Originally Posted by chrone View Post
Yeap, it reset the audio to its default level. I could send you a logcat, direct message me where to send though.

Sent from my Nexus 5
Quote:
Originally Posted by chrone View Post
Oh I see, my bad.
Please try latest test build from following link. Audio issue may be fixed.
https://sites.google.com/site/mxvpen...ion/test-build

Thanks
MX Player Developer
The Following 2 Users Say Thank You to bleu8888 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes