Google Announces Plans for Projects Titan, Loon and Link

The post Google Announces Plans for Projects Titan, Loon and Link appeared first on … more

Here’s What the HTC One M9 Camera Can Do

more

Get S6 Edge’s Notifications with Edge Color Notification

The post Get S6 Edge’s Notifications with Edge Color Notification … more

Intel at MWC 2015: New Chip Branding and Details

more
Post Reply

[Question] HW+ as Default for Local Files Does Not Stick...

OP Aeroplane

28th May 2014, 06:57 PM   |  #11  
ktsamy's Avatar
Senior Member
Thanks Meter: 2,238
 
759 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by Aeroplane

Hi there,

Here it is.

Thanks again for taking the time to look into this.

The media info you have posted earlier was having Sorenson Spark h263 video in mp4 container.
The attcahed video is AVC/h264 in mp4 container.

I have tested the file you have attached. But, After enabling HW+ decoder It directly plays in HW+ in my test.
There is no problem with MX Player. Your are doing something wrong while following the instructions.

Are you trying to play the file from network share/ SMB share?
If it so , Then you have to enable HW+ Decoder (Network) too.

If you are not then Open Settings >> General >> Clear History
Enable HW+ Decoder (Local) from Settings >> Decoder

Then Try again.
5th June 2014, 10:05 PM   |  #12  
OP Junior Member
Thanks Meter: 9
 
13 posts
Join Date:Joined: Dec 2011
LIST -> SCAN -> File Extensions :)
Quote:
Originally Posted by ktsamy

The media info you have posted earlier was having Sorenson Spark h263 video in mp4 container.
The attcahed video is AVC/h264 in mp4 container.

I have tested the file you have attached. But, After enabling HW+ decoder It directly plays in HW+ in my test.
There is no problem with MX Player. Your are doing something wrong while following the instructions.

Are you trying to play the file from network share/ SMB share?
If it so , Then you have to enable HW+ Decoder (Network) too.

If you are not then Open Settings >> General >> Clear History
Enable HW+ Decoder (Local) from Settings >> Decoder

Then Try again.




I went through the whole SETTINGS, one configurable setting after another and this time realized that there was another way, a more specific way, to configure the codec to be used, for a particular type of file extension. Which means we can configure the type of codec to be used (whether HW, HW+, or SW) for any specific file extension (mp4, wmv, flv, or any and every file extension) in SETTINGS -> LIST -> SCAN -> FILE EXTENSION. I believe this "more specific" setting overrides SETTINGS -> DECODER -> HARDWARE DECODER and SOFTWARE DECODER which are more general configurable settings.

And this explains why no matter how I change the DECODER settings to use HW+ codec for my local files, MXplayer still plays the music video using HW. Because the first time I ever used MXplayer I already configured MXplayer to use HW codec for all mp4 files in SETTINGS -> LIST -> SCAN -> FILE EXTENSION. Its been almost 3 years using MXplayer that it has slipped my mind. This setting by the way, though not really located deep in the underbelly of SETTINGS, is quite a bit off from the DECODER Settings.

Kindly accept my apologies for all this. My tail is down between my legs in shame And I also felt I needed to post this for the thread to go full-circle, and who knows?, a satisfied but wondering MXplayer user might come onto this thread and say "Eureka !". It is still a valid and useful thread I believe.


Thank you both !

Benjamin
Last edited by Aeroplane; 5th June 2014 at 10:10 PM. Reason: sorry!
The Following User Says Thank You to Aeroplane For This Useful Post: [ View ]
7th June 2014, 07:15 AM   |  #13  
CDB-Man's Avatar
Senior Member
Thanks Meter: 166
 
628 posts
Join Date:Joined: May 2013
More
You are definitely right that most people would not even think to go there.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes