FORUMS

XeroAsh Theme for CM12

This theme by XDA Senior Member balrajs99 features a black and slate gray UI that gives your phone a … more

Samsung Galaxy S6 To Receive Major Camera Update

When the Samsung Galaxy S6 and S6 Edge were launched, they became the prime focus for … more

Tactile: An Addicting Game with Beautiful Material Design

The game industry has been around for decades, catering to a wide … more

Android’s Consistency and The User Experience

This is a site of power users, and it is fair to say that most of us are more … more
Post Reply Subscribe to Thread Email Thread

[Solved] How to stream Bluray to MX -Player

26th April 2014, 01:33 AM |#1  
OP Junior Member
Thanks Meter: 0
 
More
It would seem that using es-explorer, where it emulates a server, causes a bandwidth or memory bottleneck when full bluray files are streamed to MX-Player.

Does anyone else know how-else I can stream to MX-Player..

What type of server/service can I setup on the PC end so perhaps MX-Player can m0ar-directly receive files..

I am trying to stream files typically 22GB to 38GB, peak bitrate is bluray standard 40Mbit..


I know that the link has enough bandwidth, since I can get over 100Mbit to the Note 3, and 90Mbit to Nexus 7.

I am also sure that the hardware is capable of playing the files, since they play fine from an SD card.
Last edited by inveterate; 26th April 2014 at 01:55 AM.
 
 
26th April 2014, 08:22 AM |#2  
ktsamy's Avatar
Senior Member
Thanks Meter: 2,431
 
More
Quote:
Originally Posted by inveterate

It would seem that using es-explorer, where it emulates a server, causes a bandwidth or memory bottleneck when full bluray files are streamed to MX-Player.

Does anyone else know how-else I can stream to MX-Player..

What type of server/service can I setup on the PC end so perhaps MX-Player can m0ar-directly receive files..

I am trying to stream files typically 22GB to 38GB, peak bitrate is bluray standard 40Mbit..


I know that the link has enough bandwidth, since I can get over 100Mbit to the Note 3, and 90Mbit to Nexus 7.

I am also sure that the hardware is capable of playing the files, since they play fine from an SD card.

Enable SW Decoder (Network) from Settings > Decoder

Then try again.

Sent from my Micromax A116 using Tapatalk
26th April 2014, 06:19 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ktsamy

Enable SW Decoder (Network) from Settings > Decoder

Then try again.

Sent from my Micromax A116 using Tapatalk

I tried enabling software.. the network stats remain the same..

the player itself is even choppier.. seems to only play smoothly (for a second) with HW+, then the server emulation bottle neck occurs
Last edited by inveterate; 26th April 2014 at 06:33 PM.
27th April 2014, 04:46 PM |#4  
ktsamy's Avatar
Senior Member
Thanks Meter: 2,431
 
More
Quote:
Originally Posted by inveterate

I tried enabling software.. the network stats remain the same..

the player itself is even choppier.. seems to only play smoothly (for a second) with HW+, then the server emulation bottle neck occurs

can you post a logcat?
27th April 2014, 05:34 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ktsamy

can you post a logcat?

I am not rooted.. is there a logcat app that will run concurrently without root?
28th April 2014, 10:27 AM |#6  
ktsamy's Avatar
Senior Member
Thanks Meter: 2,431
 
More
Install mx log collector.
Run it immediately after the problem. It will dump system log...!!!

Else you can do it in a PC...!!

Sent from my Micromax A116 using Tapatalk
28th April 2014, 12:18 PM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ktsamy

Install mx log collector.
Run it immediately after the problem. It will dump system log...!!!

Else you can do it in a PC...!!

Sent from my Micromax A116 using Tapatalk

Ok log attached
Attached Files
File Type: txt Log 2.txt - [Click for QR Code] (22.4 KB, 7 views)
29th April 2014, 06:39 AM |#8  
ktsamy's Avatar
Senior Member
Thanks Meter: 2,431
 
More
Quote:
Originally Posted by inveterate

Ok log attached

@bleu8888
Can you look at the problem?

Sent from my Micromax A116 using Tapatalk
Last edited by ktsamy; 30th April 2014 at 09:01 PM.
30th April 2014, 08:19 PM |#9  
Senior Member
Thanks Meter: 275
 
More
It looks like that network packet is being delayed while begin dispatched from server to MX Player.
This might one of these:
1) Streaming server -> Device
2) Device -> ES Explorer
3) ES Explorer -> MX Player

If you think 1) is not the case, it might be 2) or 3)
Would you try other apps other than ES Explorer, such as BubbleUPnP?
Last edited by bleu8888; 30th April 2014 at 08:25 PM.
The Following 2 Users Say Thank You to bleu8888 For This Useful Post: [ View ]
1st May 2014, 10:39 AM |#10  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by bleu8888

It looks like that network packet is being delayed while begin dispatched from server to MX Player.
This might one of these:
1) Streaming server -> Device
2) Device -> ES Explorer
3) ES Explorer -> MX Player

If you think 1) is not the case, it might be 2) or 3)
Would you try other apps other than ES Explorer, such as BubbleUPnP?

Yea. Es Explorer is definitely the problem

I tried bubbleupnp..

running xbmc on desktop.. everything is working.. streaming to mxplayer.. Wh00t..

Finally watching my pc videos..

the fact that I only have bluray rips didn't help, which meant i couldn't watch ANY of my pc videos.. LOL

Thank ya'll so much...

Damn you Es xplorer, grrrrrrrr................
Last edited by inveterate; 1st May 2014 at 10:58 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes