Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,223 Members 41,407 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Thumbnail cache limited?

Tip us?
 
DualJoe
Old
(Last edited by DualJoe; 4th August 2014 at 12:16 AM.)
#1  
DualJoe's Avatar
Senior Member - OP
Thanks Meter 503
Posts: 1,199
Join Date: Oct 2011
Location: DE
Default [Q] Thumbnail cache limited?

Hi,
i lose some (not all) video thumbnails every 1-2 days. Is there a maximum file count/cache size for thumbnails or something that deletes old entries? I'm pretty sure i'm not having 1706 new videos every day that would roundrobin the cache.

Edit:
My cache currently holds 1706 files with 75.4M.
/storage/sdcard1/Android/data/com.mxtech.videoplayer.ad/cache/image
Code:
# ls -1 |wc -l
1706

# du -sh
75.4M   .
Galaxy S4 LTE+ I9506:
Snapdragon800 || MSM8974
2.3GHz || 2GB Ram || Adreno330
Cyanogenmod 11
 
CDB-Man
Old
#2  
CDB-Man's Avatar
Senior Member
Thanks Meter 69
Posts: 325
Join Date: May 2013
Curious, if custom ROM, does your ROM have some sort of cache-size management?
MX Player sub-forum Moderator; Primary User Support
MX Player Sub-forum
Welcome thread and FAQ -- Feature Requests list
Please hit Thanks when someone helps you out!

The Developer/Owner of MX Player is bleu8888. Please post a thread in the MX Player sub-forum for support.
For bugs or glitches, always include an MX Log Collector report.

I do not answer MX Player questions in PM. Post a thread in the MX Player sub-forum for support.

 
DualJoe
Old
#3  
DualJoe's Avatar
Senior Member - OP
Thanks Meter 503
Posts: 1,199
Join Date: Oct 2011
Location: DE
Quote:
Originally Posted by CDB-Man View Post
Curious, if custom ROM, does your ROM have some sort of cache-size management?
No, nothing special.
I mount some video folders occasionally to /mnt/cifs/ that get scanned by mx player as well. Maybe that confuses mx player. But if i remember correctly it also happened between two non-cifs sessions already.

The mx coder is not here? Only at Google forums?
Galaxy S4 LTE+ I9506:
Snapdragon800 || MSM8974
2.3GHz || 2GB Ram || Adreno330
Cyanogenmod 11
 
CDB-Man
Old
#4  
CDB-Man's Avatar
Senior Member
Thanks Meter 69
Posts: 325
Join Date: May 2013
Google Forum's been closed for a few months now, the developer's moved here along with the rest of us. See the note in my signature.
@bleu8888 is there some sort of internal MX cap on total thumbnail folder size?
MX Player sub-forum Moderator; Primary User Support
MX Player Sub-forum
Welcome thread and FAQ -- Feature Requests list
Please hit Thanks when someone helps you out!

The Developer/Owner of MX Player is bleu8888. Please post a thread in the MX Player sub-forum for support.
For bugs or glitches, always include an MX Log Collector report.

I do not answer MX Player questions in PM. Post a thread in the MX Player sub-forum for support.

The Following User Says Thank You to CDB-Man For This Useful Post: [ Click to Expand ]
 
DualJoe
Old
#5  
DualJoe's Avatar
Senior Member - OP
Thanks Meter 503
Posts: 1,199
Join Date: Oct 2011
Location: DE
My cache is still rising. Doesn't look like i'm hitting any cap here.. now 1767 files and 77.8MB.
I tested it some more and it looks like its related to the cifs share indeed (its transparent though... MX doesn't know about it. It just sees many new files). The bug seems to work "two-ways". Once cifs is mounted "local files 1" (some specific files) thumbs are missing. If i unmount cifs "local files 2" (other files) are missing. Something seems to collide here. I cannot see any relation between these files though. There are some dupe files present locally (on my phone) that are also on my desktop (cifs share) but i'm sure there are also files that are not.

I will try to setup a scenario with local files only so you can test it better. Will report back.
Galaxy S4 LTE+ I9506:
Snapdragon800 || MSM8974
2.3GHz || 2GB Ram || Adreno330
Cyanogenmod 11
 
bleu8888
Old
#6  
Senior Member
Thanks Meter 159
Posts: 239
Join Date: Mar 2011
Quote:
Originally Posted by DualJoe View Post
My cache is still rising. Doesn't look like i'm hitting any cap here.. now 1767 files and 77.8MB.
I tested it some more and it looks like its related to the cifs share indeed (its transparent though... MX doesn't know about it. It just sees many new files). The bug seems to work "two-ways". Once cifs is mounted "local files 1" (some specific files) thumbs are missing. If i unmount cifs "local files 2" (other files) are missing. Something seems to collide here. I cannot see any relation between these files though. There are some dupe files present locally (on my phone) that are also on my desktop (cifs share) but i'm sure there are also files that are not.

I will try to setup a scenario with local files only so you can test it better. Will report back.
I will check it out. Thanks
MX Player Developer
The Following User Says Thank You to bleu8888 For This Useful Post: [ Click to Expand ]
 
bleu8888
Old
#7  
Senior Member
Thanks Meter 159
Posts: 239
Join Date: Mar 2011
Quote:
Originally Posted by DualJoe View Post
Hi,
i lose some (not all) video thumbnails every 1-2 days. Is there a maximum file count/cache size for thumbnails or something that deletes old entries? I'm pretty sure i'm not having 1706 new videos every day that would roundrobin the cache.

Edit:
My cache currently holds 1706 files with 75.4M.
/storage/sdcard1/Android/data/com.mxtech.videoplayer.ad/cache/image
Code:
# ls -1 |wc -l
1706

# du -sh
75.4M   .
I believe this issue is fixed on latest test version
https://sites.google.com/site/mxvpen...ion/test-build

Feedback will be appreciated.
Thanks
MX Player Developer
The Following User Says Thank You to bleu8888 For This Useful Post: [ Click to Expand ]
 
DualJoe
Old
(Last edited by DualJoe; 6th August 2014 at 09:21 PM.)
#8  
DualJoe's Avatar
Senior Member - OP
Thanks Meter 503
Posts: 1,199
Join Date: Oct 2011
Location: DE
Quote:
Originally Posted by bleu8888 View Post
I believe this issue is fixed on latest test version
https://sites.google.com/site/mxvpen...ion/test-build

Feedback will be appreciated.
Thanks
Thanks, but still same behavior. I flushed the cache so i can trace the cache file count better and i've noticed the cache fluctuates indeed (when i add/remove folders). I once have 139 files. Then, when i mount new folders there's 102 files only so MX seems to try to keep it clean (what actually is a good thing). But there are always the same files missing.

These are the folders i've set in MX player. The cifs folder is either not present, empty or filled depending if mounted or not. Not sure if MX Player gets maybe confused by that behavior.

Galaxy S4 LTE+ I9506:
Snapdragon800 || MSM8974
2.3GHz || 2GB Ram || Adreno330
Cyanogenmod 11
 
bleu8888
Old
#9  
Senior Member
Thanks Meter 159
Posts: 239
Join Date: Mar 2011
Quote:
Originally Posted by DualJoe View Post
Thanks, but still same behavior. I flushed the cache so i can trace the cache file count better and i've noticed the cache fluctuates indeed (when i add/remove folders). I once have 139 files. Then, when i mount new folders there's 102 files only so MX seems to try to keep it clean (what actually is a good thing). But there are always the same files missing.

These are the folders i've set in MX player. The cifs folder is either not present, empty or filled depending if mounted or not. Not sure if MX Player gets maybe confused by that behavior.

Woud you try again using latest beta version?
https://sites.google.com/site/mxvpen...ion/test-build

There is a rule for thumbnail extraction. If thumbnail extraction failed once, MX will never try again.
If storage is mounted from CIFS, MX Player will fail to extract thumbnail frequently. So it will not try to extract thumbnail because it failed once. This issue might be fixed on this build.

To make it work correctly, clear entire MX Player data.
MX Player Developer
The Following User Says Thank You to bleu8888 For This Useful Post: [ Click to Expand ]
 
DualJoe
Old
#10  
DualJoe's Avatar
Senior Member - OP
Thanks Meter 503
Posts: 1,199
Join Date: Oct 2011
Location: DE
Quote:
Originally Posted by bleu8888 View Post
Woud you try again using latest beta version?
https://sites.google.com/site/mxvpen...ion/test-build
Bingo! Works. Thank you very much.
Galaxy S4 LTE+ I9506:
Snapdragon800 || MSM8974
2.3GHz || 2GB Ram || Adreno330
Cyanogenmod 11

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes