Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more

Boost the Brightness of Your Sony Xperia Z1’s LED

I think the last time anyone has ever used a physical torch to find their earphones, … more
Post Reply

[Q] Battery life drain

13th August 2014, 05:40 PM   |  #1  
OP Junior Member
Thanks Meter: 3
 
13 posts
Join Date:Joined: Aug 2014
Hi,
Since I have installed kitkat ( b510, b511 and now b512) after my battery gets to 9%, it drains so fast, in 1 minute with the screen on, is at 4% and after just 20-40 seconds, is shutting down. I have sync on, a bunch of notifications, but really, 9% in 2 minutes.
The battery life is not perfect, but from 100% to 9% i have to say it drains normally .
I am the only one who is experiencing this? What can i do about it?
14th August 2014, 02:07 PM   |  #2  
kolembo's Avatar
Senior Member
Thanks Meter: 156
 
343 posts
Join Date:Joined: Nov 2012
At 9% try the ultra power saver and see.

Sent from my HUAWEI P6-U06 using XDA Premium HD app
15th August 2014, 10:02 PM   |  #3  
Member
Thanks Meter: 5
 
86 posts
Join Date:Joined: Dec 2012
I have this too. Somehow it just shows wrong %. Ultra power saving lasted 1min at 9% left
16th August 2014, 05:02 AM   |  #4  
Junior Member
Thanks Meter: 1
 
14 posts
Join Date:Joined: Oct 2013
Same here I've experienced same battery problem also, mine starts at 10% sometimes 12% then the battery level would drop very fast until it shutdown. Ultra Power can't solve it..
16th August 2014, 10:15 AM   |  #5  
Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Dec 2011
Same here, below 10% it drains very quickly.
16th August 2014, 12:38 PM   |  #6  
Tallmedic's Avatar
Junior Member
Thanks Meter: 0
 
19 posts
Join Date:Joined: May 2014
mine too .. :/ (after 10%)
18th August 2014, 10:11 PM   |  #7  
danielpsx's Avatar
Junior Member
Flag maracay
Thanks Meter: 3
 
15 posts
Join Date:Joined: Apr 2014
More
Lightbulb
Try doing a wipe from the recovery (or factory settings reset) to see if there is some app that drains fast the battery, I think that you must replace the battery in the worst case.... Good luck dude.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Ascend P6 Q&A, Help & Troubleshooting by ThreadRank