S6 Pre-orders on T-Mobile are Arriving

T-Mobile appears to be first off the mark with delivering the S6, as some customers are already … more

Best Alarm App for Android?

There are tons of choices to choose from when looking for a great alarm app for Android. While the stock … more

Unofficial CM12.1 Available for Moto E 2014

While Motorola is yet to release a final 5.0.2 build for the Moto E 2014, XDA Senior … more

Pinsy Brings Social Sketching To Your Watch & Phone

Did you watch Apple’s VP draw on his wrist during the Apple Watch announcement … more
Post Reply Subscribe to Thread Email Thread

[Q] Wifi disconnect problem, might have worked out what's causing it...

20th October 2014, 01:20 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Apr 2014
(Firstly I know I just posted and said Surdu Petru's Kit Kat Carbon Rom is awesome and it is. So is his Omni Rom which I just changed from. The wifi problem isn't caused by the roms. it's been happening with all sorts of Roms for me (and loads of other people on other phones)

I noticed before when I installed his Omni Rom ( and at least 5x before with other roms) that the WiFi was working perfectly until some point between a Google restore & titanium backup - restore. Then I'd start getting the WiFi disconnecting every 30 seconds, even when standing next to the router on my home network.
I Googled and tried everything I could find but nothing would work. So when I installed Carbon Rom a few days ago I flashed the rom and let it install to the Google log in, connected to WiFi and signed into my Google account BUT I didn't allow Google to restore data etc, just let it log in & didn't do a full titanium restore. I then slowly (Titanium Backup) restored all my apps individually that I wanted but MOST of them I just restored the app and not the data. Everything has been perfect for two days, full strong five bar WiFi signal throughout my house, never dropping the WiFi until about 1hr ago... when I opened up Google maps , accepted it's access & (we will learn everything about you) permissions, clicked on the maps GPS logo, it asked me to go to location settings, went there, approved high accuracy and BOOM, WiFi disconnected and my WiFi now says not in range. So... is it going to some server and changing my location in the phone so now it doesn't think I'm where I am and therefore doesn't want to connect to the router 1 meter from me with five bars on the phone but "not within range"? Is this what could be causing problems for loads of people on different phones?
Tried everything to get it to reconnect (Wifi On/Off, Airplane mode on/off, Wifi advanced settings re weak connection etc, Rebooted phone and nothing worked.

Did another Google search and found this forum

http://www.reddit.com/r/nexus4/comme..._my_nexus_4_a/

where about halfway down it mentions to disable hangouts and log out of Google+ then reboot. I did this and now my WiFi is back to full signal and not dropping connection.

So is this the solution to this? I haven't yet re-signed into Google+ or enabled hangouts or re-opened Google Maps and gone through the whole process above as I'm worried it will screw up my WiFi again.

Just thought I'd put this out there hoping that a developer, such as the Excellent Surdu Petru, might "click" and come up with a fix.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes