FORUMS

ZenFone 2 Lolliflash and ZenPower Giveaway!

We recently did an in-depth review of the Asus Zenfone 2 but one of the things people may … more

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

[Q] How to get HDMI-out functioning? Atrix HD

7 posts
Thanks Meter: 0
 
By interestor, Junior Member on 17th August 2014, 07:46 PM
Post Reply Subscribe to Thread Email Thread
I got an adapter for the HDMI outlet. When I use it to connect the phone to tv or monitor, the big screen says no signal.

When attached, the phone does rotate the home screen, which it does not do normally, so I think that the adapter is working.

I have Cyanogenmod android 4.4.4. There are no settings for hdmi, no Overscan like stock OS (there is only Expanded Desktop, whatever that is).

Is there some setting I have overlooked? Is there something else I should do to get the signal out to the monitor? Is my adapter not working?

Thanks
 
 
17th August 2014, 08:08 PM |#2  
Dr. Orange's Avatar
Senior Member
Thanks Meter: 79
 
More
It works for me using CarbonROM 08/04 build using an HDMI to micro HDMI adapter. Also there aren't any settings because I think only atrix HD and maybe a couple others have an HDMI out port. Did you get a Motorola factory micro HDMI to HDMI cable? Or did you buy an adapter like mine?
17th August 2014, 09:32 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
I have the small adapter, no cord.
17th August 2014, 10:01 PM |#4  
Junior Member
Flag Jo„o Pessoa
Thanks Meter: 0
 
More
I bought an adapter from ebay, the cheapest i could find, and it works no problem with one of my hdmi cable, i have a longer one that stays with no signal, test a different cable.
18th August 2014, 12:14 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
When you plug the cable and adapter into the phone, does the monitor just blink on and show the phone screen?

Also, does the phone's home screen only rotate after being plugged into the monitor? (like mine does)

My cables to the tv and monitor definitely work. The adapter might not, but its affecting the home screen rotation makes me think it does work; then maybe Cyanogenmod or Android 4.4.4 doesn't work.
Last edited by interestor; 18th August 2014 at 01:32 AM.
18th August 2014, 08:57 AM |#6  
Quote:
Originally Posted by interestor

I got an adapter for the HDMI outlet. When I use it to connect the phone to tv or monitor, the big screen says no signal.

When attached, the phone does rotate the home screen, which it does not do normally, so I think that the adapter is working.

I have Cyanogenmod android 4.4.4. There are no settings for hdmi, no Overscan like stock OS (there is only Expanded Desktop, whatever that is).

Is there some setting I have overlooked? Is there something else I should do to get the signal out to the monitor? Is my adapter not working?

Thanks

The adapter should be working based off of what you described. I'm sitting on the 20140102 revision of 4.3.1 and I see the same thing on my device. Only difference is that I do get a signal. No HDMI option in any menu present. Expanded Desktop is full screen mode and should be used with a BT mouse or Pie. I don't believe there is anything you have overlooked, but then again I have yet to really start playing with KK on my daily device (currently running stable version on DX and alpha version on A4G)
19th August 2014, 01:49 AM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Thanks for the inputs.

Whoop, I see I actually have Android 4.4.2 if that matters.
I have Cyanogenmod 11.0-20140109

I would like to hear if anyone uses either of these and hdmi.
21st August 2014, 06:37 AM |#8  
techdeisel's Avatar
Senior Member
Thanks Meter: 46
 
More
I only have lap dock to connect to but I also get no signal blinking screen on all ROMs I've tried except for stock based I even tried Dr orange's suggested 8/4 carbon build
6th January 2015, 03:20 AM |#9  
Senior Member
Thanks Meter: 653
 
More
Quote:
Originally Posted by interestor

When you plug the cable and adapter into the phone, does the monitor just blink on and show the phone screen?

Also, does the phone's home screen only rotate after being plugged into the monitor? (like mine does)

My cables to the tv and monitor definitely work. The adapter might not, but its affecting the home screen rotation makes me think it does work; then maybe Cyanogenmod or Android 4.4.4 doesn't work.

I'm a little late on this but since I just tested this today: This may be a CM or KK thing as you say. I had the same symptoms you reported when testing with AHD on CM11 1/1/15 msm8960 jbbl nightly but with the same TV setup and cables stock JB phone system worked great with HDMI. More detail From this post http://forum.xda-developers.com/show...&postcount=676 which I posted put up before discovering this thread.(text pasted below)

"I got a Micro HDMI male to HDMI female adapter and had a chance to test in the 1/1/15 MSM8960 JBBL nightly . It did not work although the phone and TV were clearly talking through the cable when connected:

- Phone media sound mutes.
- Phone goes into forced landscape mode for all screens including desktop regardless of native and theme based rotation settings.
- TV screen input type displays HDMI for a few seconds before fading (an indication that TV has seen an HDMI device).
- When cable is disconnected a flash of colored squares on the TV indicates a change of state at the TV, the phone goes back to portrait mode and resumes playing sound.

From what I've read this may still be a limitation of CM but there is also a lesser possibility that this is due to limitations of the TV. The only reports of successful HDMI connections I've seen for the Atrix HD are in stock but I did not have long enough access to the test rig to try stock and eliminate TV and cabling as potential issues. Will do that next chance I get.

[EDIT] Tested in stock on the same gear and HDMI worked great. Phone went into landscape as described above and the TV picked up the image of the desktop fine with minimal cropping of the side edges - possibly correctable at the TV. Media audio plays to TV through HDMI connection with no addition configuration required at TV or phone. Not sure what (if anything) is missing from CM in regards to to fully negotiating the connection and sending the video/audio."
Last edited by IronTechmonkey; 6th January 2015 at 05:39 AM.
29th January 2015, 05:39 AM |#10  
Senior Member
Thanks Meter: 653
 
More
Still chasing functional HDMI out in CM. From my recent post of testing results at the AHD CM thread http://forum.xda-developers.com/show...postcount=683:

HDMI-Micro out fail

HDMI-mico out still Not Working in anything but stock JB. CM and other KK builds not working including the following:

- CM11 msm8960 jbbl 1/1/15 nighlty in ART.
- CM11 msm8960 jbbl 1/19/15 nighlty in Dalvik (converted to Dalvik from ART)
- CM11 msm8960 jbbl 1/25/15 nighlty in Dalvik having never been in ART
- Clean flash of Validus msm8960 jbbl Lollipop (no gapps)
- Clean flash of CM11 msm8960 jbbl 1/19/15 nighlty in Dalvik (no gapps)
- CM11 msm8960 jbbl 1/25/15 nighlty in Dalvik having never been in ART (restored)

In all of the cases listed above when HDMI cable was connected between phone and TV; Phone screen goes to landscape, media stream muted at phone speaker, and TV flashes as if about to receive signal but no video or audio on TV.

I cant think of a reason why the TV would be able to receive properly from stock JB but not any of the other builds on the same device. In the interest of thoroughness I have to test on a different TV. Beyond that I donít know.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes