FORUMS

AT&T address book sync

41 posts
Thanks Meter: 14
 
By 556AR, Member on 23rd June 2014, 11:58 PM
Post Reply Subscribe to Thread Email Thread
Has anyone found a way to disable this yet? It pops up every time I open the contacts app.
 
 
24th June 2014, 03:31 AM |#2  
Senior Member
Thanks Meter: 197
 
More
Quote:
Originally Posted by 556AR

Has anyone found a way to disable this yet? It pops up every time I open the contacts app.

Only way I was able to disable it on my s4 was to edit an xml file. You have to be rooted and have something like root explorer then go to
Data/data/com.android.contacts/shared_pref and edit the xml file there to tell it to not search AT&T for their cloud address book. Below is an example of mine. You can see where I've changed some values to false in regards to the AT&T address book.

<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<map>
<string name="runtime_firstboot_time">1403537567925</string>
<boolean name="REGISTRATION_COMPLETE_FLAG" value="true" />
<int name="adn_editable" value="1" />
<int name="csc_pref_key_max_recipient" value="10" />
<boolean name="showContactTips" value="true" />
<int name="AIRPLANE_MODE_DB_UPDATED" value="0" />
<int name="actionBarAdapter.lastTab" value="2" />
<string name="ContactEditorUtils_default_account">vnd.sec. contact.phonevnd.sec.contact.phone</string>
<boolean name="INIT_SYNC_FLAG" value="false" />
<boolean name="AAB_ENABLED_FLAG" value="false" />
<int name="online_search" value="1" />
<int name="SIM_CONATACTS" value="0" />
<int name="sim_db_ready" value="1" />
<string name="SIMSERIAL">(you sum serial will show here)</string>
<string name="ContactEditorUtils_known_accounts">vnd.sec.c ontact.phonevnd.sec.contact.phoneprimary.sim.accou nt_namevnd.sec.contact.sim(your email address is displayed here)com.google</string>
<boolean name="ContactEditorUtils_anything_saved" value="true" />
<int name="REGISTRATION_COUNT_FLAG" value="4" />
<string name="FIELD_URL">http://mobile.ws.addressbook.att.net/SubscriberService</string>
<string name="IMSI">(your imsi is here) </string>
<int name="setInitialMyProfile" value="1" />
<int name="airplane_mode_changed" value="0" />
<string name="FIELD_NAMESPACE">http://pat.ws.aab.att.com/webService/MobileSubscriber</string>
<boolean name="SIM_IMPORT_FLAG" value="false" />
<int name="DialtactsActivity_last_manually_selected_tab " value="0" />
</map>


Sent from my SAMSUNG-SGH-I337 using XDA Premium 4 mobile app
24th June 2014, 11:39 AM |#3  
galaxy s4 nutjob's Avatar
Senior Member
Flag Niagara Falls
Thanks Meter: 34
 
Donate to Me
More
Quote:
Originally Posted by drock212

Only way I was able to disable it on my s4 was to edit an xml file. You have to be rooted and have something like root explorer then go to
Data/data/com.android.contacts/shared_pref and edit the xml file there to tell it to not search AT&T for their cloud address book. Below is an example of mine. You can see where I've changed some values to false in regards to the AT&T address book.

<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<map>
<string name="runtime_firstboot_time">1403537567925</string>
<boolean name="REGISTRATION_COMPLETE_FLAG" value="true" />
<int name="adn_editable" value="1" />
<int name="csc_pref_key_max_recipient" value="10" />
<boolean name="showContactTips" value="true" />
<int name="AIRPLANE_MODE_DB_UPDATED" value="0" />
<int name="actionBarAdapter.lastTab" value="2" />
<string name="ContactEditorUtils_default_account">vnd.sec. contact.phonevnd.sec.contact.phone</string>
<boolean name="INIT_SYNC_FLAG" value="false" />
<boolean name="AAB_ENABLED_FLAG" value="false" />
<int name="online_search" value="1" />
<int name="SIM_CONATACTS" value="0" />
<int name="sim_db_ready" value="1" />
<string name="SIMSERIAL">(you sum serial will show here)</string>
<string name="ContactEditorUtils_known_accounts">vnd.sec.c ontact.phonevnd.sec.contact.phoneprimary.sim.accou nt_namevnd.sec.contact.sim(your email address is displayed here)com.google</string>
<boolean name="ContactEditorUtils_anything_saved" value="true" />
<int name="REGISTRATION_COUNT_FLAG" value="4" />
<string name="FIELD_URL">http://mobile.ws.addressbook.att.net/SubscriberService</string>
<string name="IMSI">(your imsi is here) </string>
<int name="setInitialMyProfile" value="1" />
<int name="airplane_mode_changed" value="0" />
<string name="FIELD_NAMESPACE">http://pat.ws.aab.att.com/webService/MobileSubscriber</string>
<boolean name="SIM_IMPORT_FLAG" value="false" />
<int name="DialtactsActivity_last_manually_selected_tab " value="0" />
</map>


Sent from my SAMSUNG-SGH-I337 using XDA Premium 4 mobile app

Thanks for the help
24th June 2014, 06:02 PM |#4  
DedNyte's Avatar
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by 556AR

Has anyone found a way to disable this yet? It pops up every time I open the contacts app.

I had this problem but it would try to sync everytime i open an app. contacts then settings then contacts then at&t address book and there should be a setting ti turn it off.

Sent from my SAMSUNG-SM-G900A using XDA Free mobile app
24th June 2014, 06:32 PM |#5  
Senior Member
Thanks Meter: 42
 
More
Quote:
Originally Posted by DedNyte

I had this problem but it would try to sync everytime i open an app. contacts then settings then contacts then at&t address book and there should be a setting ti turn it off.

Don't need root to disable this. It took me a while when I first got the phone, but it's buried deep in the settings. I think I had to reboot after turning it off to stop the splash screen from popping up every time I opened contacts.

I mean come on, I sync with google, I don't need redundant AT&T and Samsung "cloud" address books.
24th June 2014, 10:32 PM |#6  
OP Member
Thanks Meter: 14
 
More
Quote:
Originally Posted by LoSt180

Don't need root to disable this. It took me a while when I first got the phone, but it's buried deep in the settings. I think I had to reboot after turning it off to stop the splash screen from popping up every time I opened contacts.

I mean come on, I sync with google, I don't need redundant AT&T and Samsung "cloud" address books.

Where is the setting located?
24th June 2014, 10:53 PM |#7  
norbarb's Avatar
Senior Member
Flag Crest Hill
Thanks Meter: 871
 
Donate to Me
More
Quote:
Originally Posted by 556AR

Has anyone found a way to disable this yet? It pops up every time I open the contacts app.

Open address book go to settings then contacts AT&T address book and turn off auto sync

Swiping from dark side of Galaxy S5.
24th June 2014, 10:59 PM |#8  
OP Member
Thanks Meter: 14
 
More
Quote:
Originally Posted by norbarb

Open address book go to settings then contacts AT&T address book and turn off auto sync

Swiping from dark side of Galaxy S5.

I've tried checking there before it just takes me to a screen about registering for it. No option to disable.

Sent from my SAMSUNG-SM-G900A using Tapatalk
24th June 2014, 11:01 PM |#9  
norbarb's Avatar
Senior Member
Flag Crest Hill
Thanks Meter: 871
 
Donate to Me
More
Quote:
Originally Posted by 556AR

Where is the setting located?

3 dots on top right corner or hold left button next to home button when you open contacts.

Swiping from dark side of Galaxy S5.

---------- Post added at 05:01 PM ---------- Previous post was at 04:59 PM ----------

Quote:
Originally Posted by 556AR

I've tried checking there before it just takes me to a screen about registering for it. No option to disable.

Sent from my SAMSUNG-SM-G900A using Tapatalk

Then try to register and disable then

Swiping from dark side of Galaxy S5.
26th June 2014, 08:29 PM |#10  
Junior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by norbarb

3 dots on top right corner or hold left button next to home button when you open contacts.

Swiping from dark side of Galaxy S5.

---------- Post added at 05:01 PM ---------- Previous post was at 04:59 PM ----------



Then try to register and disable then

Swiping from dark side of Galaxy S5.

The only problem with this is if you dont have an at&t account, you can't disable it this way because you won't be taken to a registration page. So how do you disable it if you use straight talk or any other service that uses at&t towers but isnt directly at&t? I would like to know this too and that's probably what the other person was asking. I don't see anything that can be disabled in system and i can't make it quit popping up.

Sent from my SAMSUNG-SM-G900A using XDA Free mobile app
26th June 2014, 09:31 PM |#11  
jm2k7's Avatar
Senior Member
Flag Black Mesa :P
Thanks Meter: 66
 
More
Quote:
Originally Posted by miller1821

The only problem with this is if you dont have an at&t account, you can't disable it this way because you won't be taken to a registration page. So how do you disable it if you use straight talk or any other service that uses at&t towers but isnt directly at&t? I would like to know this too and that's probably what the other person was asking. I don't see anything that can be disabled in system and i can't make it quit popping up.

Sent from my SAMSUNG-SM-G900A using XDA Free mobile app

for those who use the phone with another carrier, no option to disable it just does not appear, at first it's annoying, but after 3 or 4 attempts to divert pressing the back button not bother asking again sync with att.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes