FORUMS

Top Forum Discussions

Mobile Hotspot for Another Carrier

175 posts
Thanks Meter: 66
 
By jm2k7, Senior Member on 1st July 2014, 11:53 PM
Post Reply Subscribe to Thread Email Thread
5th December 2014, 04:41 PM |#11  
Member
Flag Port au Prince
Thanks Meter: 3
 
More
Just want to confirm that it works on ATT S5 with Digicel in Haiti
 
 
7th January 2015, 03:45 PM |#12  
Junior Member
Flag loxley, Alabama
Thanks Meter: 0
 
Donate to Me
More
will this work on an S5 G900A ATT usa
Quote:
Originally Posted by jm2k7

Requirements:

  • Root
  • SuperUser
  • ES Explorer

Description:
Resolves that annoying "Mobile data is not avaible or invalid SIM" when enabled Mobile Hotspot.



Procedure:

1. Open "ES File Explorer". Go to the left side in "Fast Access" in the "Tools" section and then enable "Root Explorer" to have root permissions on the file browser.

2. Remove the Oldest "TetheringProvision.apk" and "TetheringProvision.odex" in system/app and replace with "TetheringProvision.apk" in: system/app
check and set permission rw-r--r--

Pros: Work with another Carrier.
Cons: Maybe not work well for at&t carrier, FC in ART Mode.

note: I'll post it in case someone needs it.

source: http://forum.xda-developers.com/show....php?t=2310850

I just purchased an SM-G900A ATT s5 from ebay and I am getting that dang Hotspot not available error also.
I am using a Straight Talk ATT sim so the phone does work well everything EXCEPT the HotSpot!
I am assuming this is because it is not unlocked? I haven't rooted it yet, but am considering trying your fix.
My main question other than is it NOT rooted is will this fix work on the G900A? the type in your image is a 'S5 2828'.
Thanks in advance!
14th January 2015, 05:00 PM |#13  
Junior Member
Thanks Meter: 1
 
More
it working with movistar ecuador. thanks.

Quote:
Originally Posted by jm2k7

Requirements:

  • Root
  • SuperUser
  • ES Explorer

Description:
Resolves that annoying "Mobile data is not avaible or invalid SIM" when enabled Mobile Hotspot.



Procedure:

1. Open "ES File Explorer". Go to the left side in "Fast Access" in the "Tools" section and then enable "Root Explorer" to have root permissions on the file browser.

2. Remove the Oldest "TetheringProvision.apk" and "TetheringProvision.odex" in system/app and replace with "TetheringProvision.apk" in: system/app
check and set permission rw-r--r--

Pros: Work with another Carrier.
Cons: Maybe not work well for at&t carrier, FC in ART Mode.

note: I'll post it in case someone needs it.

source: http://forum.xda-developers.com/show....php?t=2310850

5th February 2015, 02:03 PM |#14  
Junior Member
Flag DC
Thanks Meter: 0
 
More
This procedure works perfectly with AT&T S5 (SM-G900A).
4th March 2015, 01:45 AM |#15  
elbaroark's Avatar
Junior Member
Flag Sturgeon
Thanks Meter: 1
 
More
Smile Mobile Hotspot for Another Carrier
I am using an AT&T S3 on Net10 network and had been trying to figure out how to get rid of the stupid error message. This method works great for me.
Post Reply Subscribe to Thread

Tags
galaxy s5 at&t, hotspot, tether
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes