Post Reply

[Q][KERNEL] building external modules

OP norwat

6th March 2014, 01:28 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2010
Hi

Im running a Wiko Darkside, a clone of Micromax A210 and i've downloaded the source code from wikogeek (FR version) and im trying to compile the RTL8187 driver
Im able to compile the modules with no errors, but i always get unknown symbol error when i try to insmod it

Code:
Unknown symbol kmem_cache_alloc_trace
I think it might have something to do with the kernel config, since theres no /proc/config.gz so im guessing that the .config provided in the source tree is the default one.

this is my build command (from the README file included in the source archive)

Code:
make TARGET_PRODUCT=wiko CFLAGS_MODULE=-fno-pic MTK_ROOT_CUSTOM=../mediatek/custom// CONFIG_DEBUG_SECTION_MISMATCH=y -j3 modulee
I've been around this error for a while and still haven't found a way to solve this so any tips on how to solve this ?
Better yet, can i flash the device with a custom/newer/better kernel without losing the data ? If so can you point me to a guide on how to do it ?

Thanks
7th March 2014, 07:12 AM   |  #2  
Guest
Thanks Meter: 325
 
0 posts
Join Date:Joined: Jan 1970
More
Quote:
Originally Posted by norwat

Hi

Im running a Wiko Darkside, a clone of Micromax A210 and i've downloaded the source code from wikogeek (FR version) and im trying to compile the RTL8187 driver
Im able to compile the modules with no errors, but i always get unknown symbol error when i try to insmod it

Code:
Unknown symbol kmem_cache_alloc_trace
I think it might have something to do with the kernel config, since theres no /proc/config.gz so im guessing that the .config provided in the source tree is the default one.

this is my build command (from the README file included in the source archive)

Code:
make TARGET_PRODUCT=wiko CFLAGS_MODULE=-fno-pic MTK_ROOT_CUSTOM=../mediatek/custom// CONFIG_DEBUG_SECTION_MISMATCH=y -j3 modulee
I've been around this error for a while and still haven't found a way to solve this so any tips on how to solve this ?
Better yet, can i flash the device with a custom/newer/better kernel without losing the data ? If so can you point me to a guide on how to do it ?

Thanks

wiko darkside is not a clone of c4 wiko stairway is the clone & u can contact varun chitre
n these link may help you
http://forum.xda-developers.com/show....php?t=2467400
http://forum.xda-developers.com/show....php?t=2596271
7th March 2014, 05:06 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by rahilj007

wiko darkside is not a clone of c4 wiko stairway is the clone & u can contact varun chitre
n these link may help you
http://forum.xda-developers.com/show....php?t=2467400
http://forum.xda-developers.com/show....php?t=2596271

thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes