Question [Q] Bluetooth Tether Issue

So, I have two Glides. I flashed them both using (I think) an identical 4.0.4 firmware since neither seemed to want to be upgraded via Kies for some reason. I'm a sucker for sliders and this still seems like the best full keyboard phone available to AT&T users, hence why I grabbed two. The first phone worked great with BT tether, but then it had some sort of issue reading the internal SD card, making it fairly useless to me as a smartphone since most of my apps would no longer work. Since I didn't feel like grabbing an external SD card at the moment, I switched over to the other Glide for the time being. However, one day when I needed to BT tether, I tried to turn it on, only to realize...there is no BT tether option! BT is on, paired to my Macbook, BT car audio works, it is paired to a Looxcie...but no BT tether option in the menu at all. It is on the other phone. Is there anything I can possibly do to fix this, or is this phone just, different for some reason?