Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Flashable zip and AOSP

OP haky 86

23rd August 2014, 11:58 PM   |  #1  
haky 86's Avatar
OP Senior Member
Flag San Vito Chietino
Thanks Meter: 254
 
234 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Hi mates

i would like to know if are there a way to make flashable zip automatically under aosp, after making a device tree for s2vep and compiled by fixing errors too, is generated file like system.img, recovery etc..whic command or apps to use to making flashbale one

thanks for any helps
24th August 2014, 12:29 PM   |  #2  
Tech N You's Avatar
Senior Member
Unknown Land
Thanks Meter: 208
 
416 posts
Join Date:Joined: Jul 2014
More
You need a META-INF Folder with an updater-script and update-binary file

Sent from my C5302 using XDA Free mobile app
24th August 2014, 01:05 PM   |  #3  
haky 86's Avatar
OP Senior Member
Flag San Vito Chietino
Thanks Meter: 254
 
234 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Quote:
Originally Posted by Tech N You

You need a META-INF Folder with an updater-script and update-binary file

Sent from my C5302 using XDA Free mobile app

Should be edited or just use cm11 one?
24th August 2014, 01:32 PM   |  #4  
Tech N You's Avatar
Senior Member
Unknown Land
Thanks Meter: 208
 
416 posts
Join Date:Joined: Jul 2014
More
Post
Quote:
Originally Posted by haky 86

Should be edited or just use cm11 one?

Update-binary use it of cm11 and updater-script will differ according to app or folder what you are flashing for. Updater-script needs to be altered as per convenience
The Following User Says Thank You to Tech N You For This Useful Post: [ View ]
24th August 2014, 01:54 PM   |  #5  
haky 86's Avatar
OP Senior Member
Flag San Vito Chietino
Thanks Meter: 254
 
234 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Quote:
Originally Posted by Tech N You

Update-binary use it of cm11 and updater-script will differ according to app or folder what you are flashing for. Updater-script needs to be altered as per convenience

Well i port ubuntu touch based on aosp phablet-4.4.2 after fix and remove a lot of errors, so i read that generating flashable zip is not supported under aosp source and also my s2 plus doesnt support fastboot to flash, i try to follow this sti https://wiki.ubuntu.com/Touch/Portin...ding_the_image but i dont understand it at 100%.
Post Reply Subscribe to Thread

Tags
android, aosp, port, porting, rom
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes