Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] WiFi issue in JB, is there a router setting to change?

OP axxel84

13th July 2014, 08:26 AM   |  #1  
OP Junior Member
Flag Ravenna
Thanks Meter: 1
 
21 posts
Join Date:Joined: Mar 2013
More
I just bought a Droid 4 that came with JB 4.1 from previous owner. Now I'm facing some issue with my home WiFi (I have an US Robotics USR9111 router): when I try to connect, wifi status remains stuck on "connecting.." phase and doesn't change.
I read that this can be a JB issue, so I tried also changing ROMS but got bootloop, so I restored to stock.
From what I understood, it is not possible to move to another Android version unless I unlock the bootloader, right? So all roms with another Android version that I see, will not work on my Droid for now?
I'm wondering if there can be some setting that I can change on my router to get it work with my phone, or at least if there is a way to unlock my bootloader (done some googling, but no luck)
Thank you in advance
13th July 2014, 02:02 PM   |  #2  
Member
Flag Budapest
Thanks Meter: 8
 
71 posts
Join Date:Joined: Nov 2010
More
Hi,

Have you tried a factory reset first?
The bootloader of OMAP devices cannot be unlocked. But there is a workaround, an application called SafeStrap. It's basically allows you to create multiple ROM partitions and install ROMs on them. Your stock ROM can remain untouched and you can switch between ROMs. You can install any custom ROM for the D4 this way. You can find the Safestrap topic in the development section.
This way you can test it if your issue is a ROM issue or not.
BTW, SafeStrap requires root.

Sent from my DROID4 using XDA Free mobile app
13th July 2014, 07:26 PM   |  #3  
OP Junior Member
Flag Ravenna
Thanks Meter: 1
 
21 posts
Join Date:Joined: Mar 2013
More
Thank you. I already installed Safestrap, but i come from a Sony device (Xperia Pro) and thought that SS worked like a normal recovery, and i could not install a rom with a different kernel than that on the phone. I'll try it.
Anyway, issue is rom-related and router-related: with the router at work it connects without problems, and i tried another jb rom that also worked with mine at home (came back to stock because it had other bugs).
15th July 2014, 01:47 PM   |  #4  
Member
Flag Budapest
Thanks Meter: 8
 
71 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by axxel84

Thank you. I already installed Safestrap, but i come from a Sony device (Xperia Pro) and thought that SS worked like a normal recovery, and i could not install a rom with a different kernel than that on the phone. I'll try it.
Anyway, issue is rom-related and router-related: with the router at work it connects without problems, and i tried another jb rom that also worked with mine at home (came back to stock because it had other bugs).

Stupid question, but are you using the same security settings for wireless on your router and your phone?
19th July 2014, 09:27 AM   |  #5  
OP Junior Member
Flag Ravenna
Thanks Meter: 1
 
21 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by nagim

Stupid question, but are you using the same security settings for wireless on your router and your phone?

Sorry for the late reply: of course, I tried first with my WPA password, and then, since I experienced the problem, I've unsecured my network and tried another time setting an open network type on the phone, but same issue
Post Reply Subscribe to Thread

Tags
issue, jelly bean, maserati, router, wifi
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes