Post Reply
Unhappy

Why is my phone SO #%@!* SLOW??

17th July 2014, 11:20 PM   |  #1  
OP Senior Member
Thanks Meter: 13
 
129 posts
Join Date:Joined: Aug 2011
I bought a used Droid Bionic off eBay cheap as a temporary replacement for my broken Samsung S3 to last until contract renewal time. But, this thing is just a turd. It's a PITA to use.

I'm running SlimKat in Slot 1. That's the only custom ROM I have installed. But it's just as slow if I boot the stock rom (and was before I rooted or did any customizing).

When I get a call, it rings several times before the screen wakes up so I can answer it. A couple times, the call has gone to voicemail before the screen woke up so I could answer the call. The capacitive buttons light up, it vibrates, the ringtone plays, but the screen stays dark until the 3rd ring.

Sometimes it takes 10 or 15 seconds just to get the keyboard to come up when I touch a text entry box. Doesn't matter what app or what keyboard I use.

Sometimes it takes so long for it to respond to a touch that I don't know if it registered my touch so I touch the screen again then a few seconds later it registers both touches which totally screws up whatever I was trying to do and I have to start over.

Sometimes I just want to throw this thing against a brick wall. It would be very satisfying to watch it shatter into pieces. It's frustrating me so much, I'm seriously thinking of borrowing a friend's old iPhone... Just typing that made me feel dirty, but that's how bad it is.

I don't see anybody else complaining. What's wrong with my phone?
25th July 2014, 02:37 AM   |  #2  
Junior Member
Thanks Meter: 7
 
8 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by HeathicusF

I bought a used Droid Bionic off eBay....

....I don't see anybody else complaining. What's wrong with my phone?

Have you tried running LagFix (from the Play Store; I am unable to post a link)? My phone slowed significantly over time while running CM11 nightlies; I occasionally boot into stock and run LagFix and it does clear up a fair number of slowdowns. This seems the most likely cause which would impact both stock and slot performance.
27th July 2014, 03:56 AM   |  #3  
Senior Member
Flag Surat / Gujarat i India
Thanks Meter: 96
 
193 posts
Join Date:Joined: Jan 2011
Donate to Me
More
It's not ROM but the battery that makes phone slow over the time... Old battery creates static charge and unable to generate enough discharge to run the phone.

Replace the battery with the new one.. And you are good to go...

Sent from my DROID BIONIC HD using Tapatalk
29th July 2014, 05:17 PM   |  #4  
OP Senior Member
Thanks Meter: 13
 
129 posts
Join Date:Joined: Aug 2011
I tried LagFix, but got an error saying it was incompatible.

My battery does die awfully fast, so I've ordered a replacement. I have doubts about that fixing the slowness, but I needed a new battery anyway so it won't be a total loss if it doesn't work.
29th July 2014, 07:57 PM   |  #5  
Senior Member
Thanks Meter: 15
 
206 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by HeathicusF

I bought a used Droid Bionic off eBay cheap as a temporary replacement for my broken Samsung S3 to last until contract renewal time. But, this thing is just a turd. It's a PITA to use.

I'm running SlimKat in Slot 1. That's the only custom ROM I have installed. But it's just as slow if I boot the stock rom (and was before I rooted or did any customizing).

When I get a call, it rings several times before the screen wakes up so I can answer it. A couple times, the call has gone to voicemail before the screen woke up so I could answer the call. The capacitive buttons light up, it vibrates, the ringtone plays, but the screen stays dark until the 3rd ring.

Sometimes it takes 10 or 15 seconds just to get the keyboard to come up when I touch a text entry box. Doesn't matter what app or what keyboard I use.

Sometimes it takes so long for it to respond to a touch that I don't know if it registered my touch so I touch the screen again then a few seconds later it registers both touches which totally screws up whatever I was trying to do and I have to start over.

Sometimes I just want to throw this thing against a brick wall. It would be very satisfying to watch it shatter into pieces. It's frustrating me so much, I'm seriously thinking of borrowing a friend's old iPhone... Just typing that made me feel dirty, but that's how bad it is.

I don't see anybody else complaining. What's wrong with my phone?



Not sure what you are doing to your Bionic to make it so slow. Mine is by far no speed demon but definitely not slow. Do you have a lot of unnecessary crap such as widgets, themes, etc.. running?


Quote:
Originally Posted by matriX1218

It's not ROM but the battery that makes phone slow over the time... Old battery creates static charge and unable to generate enough discharge to run the phone.

Replace the battery with the new one.. And you are good to go...

Sent from my DROID BIONIC HD using Tapatalk


That is debatable.
29th July 2014, 09:18 PM   |  #6  
OP Senior Member
Thanks Meter: 13
 
129 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by mikemikemikexxx

Not sure what you are doing to your Bionic to make it so slow. Mine is by far no speed demon but definitely not slow. Do you have a lot of unnecessary crap such as widgets, themes, etc.. running?

Not at all. The only widget I use is the calendar widget. I use Nova launcher, trimmed down to one home screen. No themes. No games. Only a handful of apps and most of those are utilities (ES File Explorer, Swifkey, Dropbox, XBMC remote, an alarm clock, etc.). Facebook is the only social media app.
30th July 2014, 01:11 PM   |  #7  
Senior Member
Thanks Meter: 15
 
206 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by HeathicusF

Not at all. The only widget I use is the calendar widget. I use Nova launcher, trimmed down to one home screen. No themes. No games. Only a handful of apps and most of those are utilities (ES File Explorer, Swifkey, Dropbox, XBMC remote, an alarm clock, etc.). Facebook is the only social media app.

That is bizarre, must be Slim Kat. I am on CM M8 and while it does have some minor slow downs sometimes but nothing what you describe.

(A good time to update SafeStrap if you are not on the newest version)
31st July 2014, 04:15 PM   |  #8  
Junior Member
Thanks Meter: 7
 
8 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by HeathicusF

I tried LagFix, but got an error saying it was incompatible.
...

LagFix has to be run from the stock install, rather than from a custom rom slot; it will then work only on the /data partition, which is normal.

Concerning the delay in pulling up the screen for an incoming call, I also have that same issue inconsistently on CM11 nightlies - it's often the third pulse of the motor before the screen wakes up. I haven't found a good solution to this, as it seems to be related to the phone being in deep sleep with the second core hot-unplugged. You may be able to increase the responsiveness at the cost of battery life by increasing the minimum processor speed or using a different governor, but I haven't experimented with this systematically enough to make a recommendation.
31st July 2014, 05:10 PM   |  #9  
OP Senior Member
Thanks Meter: 13
 
129 posts
Join Date:Joined: Aug 2011
I found a solution!!

A new Samsung Galaxy S5 will be here tomorrow.
2nd August 2014, 03:07 AM   |  #10  
Senior Member
Flag Surat / Gujarat i India
Thanks Meter: 96
 
193 posts
Join Date:Joined: Jan 2011
Donate to Me
More
[emoji23][emoji23][emoji23][emoji23][emoji23]

Sent from my M2 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes