XDA LG Development Challenge Winners

Almost 3months ago, we set out with LGto findtwo amazing apps that developers could put together … more

Wearable Apps w/ Andreas Göransson – XDA:DevCon 2014

XDA:DevCon 2014 in Manchester, UK featured quite a few interesting topics as … more

Browse Your Files with Ease using MK Explorer

Google has made quite an effort in perfecting the powerful and multi-faceted OS that we know as … more

How to Fix the Nexus Available Storage Bug – XDA TV

Is your Nexus device only showing half of the available storage as it should? Many … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Cannot unlock bootloader

OP oldguardmd

24th August 2014, 05:06 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Sep 2011
I have never tried to unlock an android phone before. My two year old HTC Droid Incredible 4G LTE is a bit bogged down with Verizon bloat, so I figured I would dive in an give it a try.

I cannot get past the first step (unlocking the bootloader and installing a custom recovery image).

I have been working off of this link: [Script] Automated Unlock/SuperCID/Temp-Root scripts for Windows and Linux

http://forum.xda-developers.com/show....php?t=2214653

I run step 1 (Unlock the bootloader), and allow it to restore. The results are as follows:

Your phone's CID is being modified to SuperCID. Once complete, your
phone will reboot to the bootloader.

2+0 records in
2+0 records out
1024 bytes transferred in 0.036 secs (28444 bytes/sec)
64 KB/s (1024 bytes in 0.015s)
64 KB/s (1024 bytes in 0.015s)
2+0 records in
2+0 records out
1024 bytes transferred in 0.002 secs (512000 bytes/sec)
< waiting for device >
...
(bootloader) cid: VZW__001
OKAY [ 0.020s]
finished. total time: 0.020s

Just above, you should see (bootloader) cid: 11111111

What am I missing?

Phone information:

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.15.0000
(bootloader) version-baseband: 1.53.06.1009
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 2.19.605.2
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: <Removed>
(bootloader) imei: <Removed>
(bootloader) product: fireball
(bootloader) platform: HBOOT-8960
(bootloader) modelid: PJ5310000
(bootloader) cidnum: VZW__001
(bootloader) battery-status: good
(bootloader) battery-voltage: 3818mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-3321eb88
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

How can I get to SUPERCID so I can get to the next step (S-OFF)...
24th August 2014, 06:30 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Sep 2011
Looks like mmcblk0p4 is getting copied at boot
So I am stepping through the script for getting temp root and SuperCID, and this is what I am finding:

Temp root is being obtained (I get a # when in the shell)
The file CID is getting copied to the flash successfully and then pulled to the local computer using the following commands:

adb shell "dd if=/dev/block/mmcblk0p4 of=/sdcard/cid"
adb pull /sdcard/cid


I have verified that the CID file gets successfully copied

The CID file is then copied presumably so you can restore it if needed. The CID is then modified using the hexalter.exe command.

dir mmcblk0p4.original > NUL 2>&1
if NOT %errorlevel%==0 copy cid mmcblk0p4.original
hexalter cid 0x214=0x31,0x31,0x31,0x31,0x31,0x31,0x31,0x31 > NUL


The file is then put back on the flash and copied to the original location

adb push cid /sdcard/
adb shell "dd if=/sdcard/cid of=/dev/block/mmcblk0p4"


All of this seems fine up to this point. When I reboot the phone these changes are lost. I am pretty sure this method no longer works, but the thread for [Script] Automated Unlock/SuperCID/Temp-Root scripts for Windows and Linux is locked, so it appears there is no way to ask the developer or note the problem.

Unless someone sees something I have missed it looks like another method is needed for these phones.
24th August 2014, 08:40 PM   |  #3  
therreid's Avatar
Member
Flag Wyoming
Thanks Meter: 8
 
92 posts
Join Date:Joined: Nov 2012
More
You need to follow the instructions in this thread.......

http://forum.xda-developers.com/show....php?t=2664460
The Following User Says Thank You to therreid For This Useful Post: [ View ]
24th August 2014, 09:03 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Sep 2011
Talking Rumrunner successful
Ran rumrunner and now I am unlocked.

http://rumrunner.us/
24th August 2014, 11:42 PM   |  #5  
therreid's Avatar
Member
Flag Wyoming
Thanks Meter: 8
 
92 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by oldguardmd

Ran rumrunner and now I am unlocked.

http://rumrunner.us/

Great. These are fantastic little phones that seem to run either Jelly Bean or KitKat very well....throw TWRP on and load a new ROM, then it will be like a new phone.
25th August 2014, 03:58 AM   |  #6  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Sep 2011
Thanks for the help.
KitKat gave me a lot of trouble today so I rolled back to my backup. I had problems accessing the cell tower and the Google store would not open up even over wireless. I found an update, but when I loaded that, it was so unstable that I couldn't even boot anymore. If you can recommend a good KitKat rom, let me know.

I greatly appreciate your help. I had spent nearly a week trying to work around the superCID issue.
25th August 2014, 01:17 PM   |  #7  
Senior Member
Flag Kalamazoo
Thanks Meter: 45
 
204 posts
Join Date:Joined: Feb 2011
More
Which kit kat were you running. The latest CM11 runs quite well on my phone.

Sent from my Nexus 7 using XDA Free mobile app
27th August 2014, 04:08 AM   |  #8  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Sep 2011
KitKat Good
Turns out I had CM11 Milestone 4... That had network problems that got worse when I tried to update it... I found the latest stable build (CM11 20140804-SNAPSHOT-M9-Fireball) and that works great.

Thanks again for your help.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes