Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,027 Members 47,829 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] Cannot change Date and Time (December 31, 1969)

Tip us?
 
saranay
Old
(Last edited by saranay; 18th July 2014 at 06:53 AM.) Reason: Problem Solved
#1  
Junior Member - OP
Thanks Meter 8
Posts: 9
Join Date: Mar 2009
Exclamation [SOLVED] Cannot change Date and Time (December 31, 1969)

I cannot change the date and time on my phone, in the setting nor shell commands.
Date and TIme selections are selectable, but will not change on apply.

On TWRP 2.7.10 Recovery shows a correct date and time.
But was it rebooted to operation system, it show my date and time back in December 31, 1969.

I have tried restore back to stock 4.4 rom and recovery. Still no luck on changing it.
And I cannot downgraded with HouseOfMoto to 4.1.x. Will get a boot loop.

Any help!?
Thank You
 
saranay
Old
#2  
Junior Member - OP
Thanks Meter 8
Posts: 9
Join Date: Mar 2009
Also, When I check all the system files ./. They are dated back in 1969-1970
Any Idea? Its the phone or software?
 
bweN diorD
Old
#3  
bweN diorD's Avatar
Senior Member
Thanks Meter 448
Posts: 1,073
Join Date: Jun 2011
Quote:
Originally Posted by saranay View Post
I cannot change the date and time on my phone, in the setting nor shell commands.
Date and TIme selections are selectable, but will not change on apply.

On TWRP 2.7.10 Recovery shows a correct date and time.
But was it rebooted to operation system, it show my date and time back in December 31, 1969.

I have tried restore back to stock 4.4 rom and recovery. Still no luck on changing it.
And I cannot downgraded with HouseOfMoto to 4.1.x. Will get a boot loop.

Any help!?
Thank You
what did you use to restore back to stock?
Show some appreciation to those who have helped you by using the Thanks button!!

One Click flash back to stock for Moto Razr HD/Maxx HD Here
[Guide] Moto Razr HD/MaxxHD flash: to KK, root, unlock the bootloader, install cwm, install twrp, or revert back to JB from KK Here
Are you a Noob and not sure where to post your question?
Noob friendly thread for questions about any device Here
To insure i see your reply, always QUOTE me or use @bweN diorD Thanks
 
saranay
Old
#4  
Junior Member - OP
Thanks Meter 8
Posts: 9
Join Date: Mar 2009
Quote:
Originally Posted by bweN diorD View Post
what did you use to restore back to stock?
I used both RSD and DROID_RAZR_HD_Utility_1.41 KK to restore back to 4.4
 
bweN diorD
Old
#5  
bweN diorD's Avatar
Senior Member
Thanks Meter 448
Posts: 1,073
Join Date: Jun 2011
Quote:
Originally Posted by saranay View Post
I used both RSD and DROID_RAZR_HD_Utility_1.41 KK to restore back to 4.4
sorry, im not able to help you.
i just wanted to be sure you weren't using a backup to restore.

you mentioned flashing back to JB and having issues. i posted a [guide] in the general forum. there is an edited JB file in there near the bottom that will flash with rsd if you want to try that.
i dont expect it to fix your issue though.
Show some appreciation to those who have helped you by using the Thanks button!!

One Click flash back to stock for Moto Razr HD/Maxx HD Here
[Guide] Moto Razr HD/MaxxHD flash: to KK, root, unlock the bootloader, install cwm, install twrp, or revert back to JB from KK Here
Are you a Noob and not sure where to post your question?
Noob friendly thread for questions about any device Here
To insure i see your reply, always QUOTE me or use @bweN diorD Thanks
The Following User Says Thank You to bweN diorD For This Useful Post: [ Click to Expand ]
 
saranay
Old
#6  
Junior Member - OP
Thanks Meter 8
Posts: 9
Join Date: Mar 2009
Yes I have tried that and get a bootloop. cleared cache, reset everything. Couldn't get pass bootloop.
Now am back on CM11 4.4
Try to set RTC, "hwclock or date" commands
It shows RTC_SET_TIME: Invalid argument

Because of the date and time is offset. Now I cannot login or access on any google services on my phone.
 
saranay
Old
#7  
Junior Member - OP
Thanks Meter 8
Posts: 9
Join Date: Mar 2009
Problem solved*
I use Windows 7, and USB driver is not update or installed correctly. I can't get a connection to USB 2.0+ on any ports.

Switched to my family computer and reflash. Got the phone boots up normal and Date & Time is corrected.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

[OTA Captured] Verizon LG G Pad 8.3 Finally Gets Official KitKat Update

It’s been almost nine months since the LG G Pad … more

Enjoy Wallpaper Overload with PhotoPhase

We don’t usually feature live wallpapers on the XDA Portal unless they are somewhat innovative … more

Monitor What Your Phone’s Camera Sees with Android Wear

Having a smart device strapped to your wrist certainly has its merits. A … more

Mod Lets You Have Stereo Speakers on Your Sony Xperia Z1 (Sort Of)

The stereo speakers onthe Sony Xperia Z2areprobably a relatively large … more