XT925 modem files for XT926 for LTE

81 posts
Thanks Meter: 10
By nagim, Member on 10th August 2014, 06:43 PM
Post Reply Subscribe to Thread Email Thread
14th August 2014, 08:17 AM |#11  
OP Member
Flag Budapest
Thanks Meter: 10
Originally Posted by Zeljko1234

Interesting, thx. Could you please send me link to that pdf? Do you have maybe pdf for Razr HD too?
Usually vendors wish to spare some money and just use the same hardware with software locks. In this case, Motorola had to have two or more separate product lines for basically the same board with different PA.

I found that googling for it (first hit), but the "problem" is with techinsights teardowns that they cost a lot of money (this was a free, public sample I think). I found no teardown for the XT926.
It's interesting to see the components of the Atrix HD, but there is a fundamental difference in my opinion, that is, the Atrix HD was created only for Verizon, so they didn't have to think about the other bands. I would like to see what amps they are using in the XT926. I haven't found any close-up naked pictures of the main PCB and the FCC internal photos are quite low res.
Maybe we need to swap also the antennas as well? As far as I know, they are band specific, too. Maybe swapping the frame (which contains the antennas) for one from an XT925 would do the trick?
14th August 2014, 04:26 PM |#12  
OP Member
Flag Budapest
Thanks Meter: 10
Originally Posted by nagim

...the Atrix HD was created only for Verizon..

I mean AT&T, sorry.

Sent from my DROID4 using XDA Free mobile app
3rd December 2014, 07:33 AM |#13  
Junior Member
Thanks Meter: 0
Is there any progress in the investigation ?
I mean is it possible or not to change the driver to use LTE in Europe on phones from for example Claro PR ?

Thx for reply.
3rd December 2014, 01:40 PM |#14  
CWGSM3VO's Avatar
Senior Member
Thanks Meter: 1,132
@kabaldan is correct.

Some of you may remember I was running the RTFR/CEE 4.4.2 soak-test on my Canadian XT925 for quite some time (simply because Rogers didn't have the 4.4.2 upgrade ready yet) and I lost my LTE. It's been explained in this thread and the CM11 thread (iirc) why I lost LTE.

Long story short -- I had French modem software flashed on my Canadian device and all I could attain was 3G, not LTE. Once Rogers released the official upgrade, I flashed the new modem software and LTE was available again.

You can flash different regions, but your still limited by the physical hardware configuration of the region it came from.
Last edited by CWGSM3VO; 3rd December 2014 at 01:42 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes