Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,436 Members 45,138 Now Online
XDA Developers Android and Mobile Development Forum

[How-To][Tutorial] Downgrade Kit Kat 4.4.2 to JB 4.1.2

Tip us?
 
alidsd
Old
(Last edited by alidsd; 18th June 2014 at 05:17 PM.)
#1  
alidsd's Avatar
Senior Member - OP
Thanks Meter 246
Posts: 459
Join Date: Jun 2011
Default [How-To][Tutorial] Downgrade Kit Kat 4.4.2 to JB 4.1.2

Hi,
I am just writing these steps to help those who want to downgrade from KK to JB due to any reason. Please use these steps at your own risk.

Some Background:
Recently I updated my Razr M to KK, it was Locked and Unrooted, but with the help of Twelroot and Motopocalypse I rooted and unlocked the BL.
Now somehow I didn't like the KK and wanted to go back to JB 4.1.2 because I was now having unlocked BL and rooted phone so it was easy but need to follow some steps to successfully downgrade to JB. So an unlocked BL and rooted with KK is must.

Prerequisite:
USB drivers for Razr M must be installed before proceeding.

Steps:

1. download the firmware file [Android 4.1.2
Blur_Version.98.30.1.XT907.Verizon.en.US
] from http://sbf.droid-developers.org/phone.php?device=8

2. extract the above archive and replace the XML file with the one in attachment.

3. put the phone into fastboot mode and flash the firmware with RSD Lite (attached)

4. reboot and now you have JB 4.1.2

If you want to install root application again and also want to flash custom recovery then please follow the Post#5 [ATTACK] (thanks ATTACK)


Note : for custom recovery you will need the fastboot.exe if you don't have it then install minimal_adb_fastboot_v1.1.3_setup.exe(attached).
Put the phone in fastboot mode, copy the recovery to c:\ and execute the below command :
fastboot flash recovery [Path to recovery image]

If it help you then don't forget to press Thanks button !
Attached Files
File Type: zip downgrade.zip - [Click for QR Code] (16.03 MB, 714 views)
Motorola Razr M - XT907
The Following 11 Users Say Thank You to alidsd For This Useful Post: [ Click to Expand ]
 
seasonone
Old
#2  
Member
Thanks Meter 15
Posts: 67
Join Date: Oct 2011
Location: Portland
Forgive my ignorance but this won't downgrade the kernel will it? I'm hoping it's possible to go from the newest OTA to the stable CM11 but I'm guessing this is new kernel JB. Either way thanks if I can't go to stable CM11 I'll stick with rooted 4.1.2.
 
ATTACK
Old
#3  
ATTACK's Avatar
Recognized Themer
Thanks Meter 1412
Posts: 1,045
Join Date: Jan 2012

 
DONATE TO ME
Once you have a unlocked bootloader, you do not need to use "root programs". All you need to do is flash a custom recovery via Mfastboot / fastboot then flash SuperSU / Superuser.

In dhacker29's folder there are 2 different recoveries.
  • "msm8960" is for 4.1.2
  • "KITKAT" is for 4.4.2
~$ locate Dev-Host
/public/ATTACK/myfiles/d-h.st
The Following 4 Users Say Thank You to ATTACK For This Useful Post: [ Click to Expand ]
 
alidsd
Old
#4  
alidsd's Avatar
Senior Member - OP
Thanks Meter 246
Posts: 459
Join Date: Jun 2011
Quote:
Originally Posted by ATTACK View Post
Once you have a unlocked bootloader, you do not need to use "root programs". All you need to do is flash a custom recovery via Mfastboot / fastboot then flash SuperSU / Superuser.

In dhacker29's folder there are 2 different recoveries.
  • "msm8960" is for 4.1.2
  • "KITKAT" is for 4.4.2
thanks ATTACK, can you please point out that which recovery is specially for 4.1.2 because there are a lot of recoveries with msm8960 in Dhacker29's folder.
One more thing if you have flashable Su and busybox zip then please attach it , i will update the OP.

thanks alot.
Motorola Razr M - XT907
The Following User Says Thank You to alidsd For This Useful Post: [ Click to Expand ]
 
ATTACK
Old
(Last edited by ATTACK; 20th June 2014 at 11:41 PM.)
#5  
ATTACK's Avatar
Recognized Themer
Thanks Meter 1412
Posts: 1,045
Join Date: Jan 2012

 
DONATE TO ME
DHACKER29's FOLDER
- LINK

JELLYBEAN 4.1.2 RECOVERIES
- CWM-6.0.4.6-swipe-moto_msm8960
- TWRP-2.7.0.0-moto_msm8960-hdpi


KITKAT 4.4.2 RECOVERIES
- CWM6049-RAZR-HD_M-KITKAT
- TWRP2710-RAZR_M-KITKAT


SUPERUSER - I'm just going to link to Chainfire's thread, Direct people to download from there.
http://forum.xda-developers.com/show....php?t=1538053

BUSYBOX
https://play.google.com/store/apps/d...busyboxonrails
~$ locate Dev-Host
/public/ATTACK/myfiles/d-h.st
The Following 7 Users Say Thank You to ATTACK For This Useful Post: [ Click to Expand ]
 
TheForceUnleashed
Old
#6  
TheForceUnleashed's Avatar
Senior Member
Thanks Meter 233
Posts: 364
Join Date: Feb 2012
Location: Louisiana
Could you go back to KK when you've downgraded to JB? Just asking this question early before the CM11 M8 release and the transition occurs.
Droid Razr M (CM11.0 4.4.3)
Nook Tablet (AOKP 4.4.2)
Nexus 5 (AOSP 4.4.3)
 
ATTACK
Old
#7  
ATTACK's Avatar
Recognized Themer
Thanks Meter 1412
Posts: 1,045
Join Date: Jan 2012

 
DONATE TO ME
Quote:
Originally Posted by TheForceUnleashed View Post
Could you go back to KK when you've downgraded to JB? Just asking this question early before the CM11 M8 release and the transition occurs.
Yes.
~$ locate Dev-Host
/public/ATTACK/myfiles/d-h.st
 
TheForceUnleashed
Old
#8  
TheForceUnleashed's Avatar
Senior Member
Thanks Meter 233
Posts: 364
Join Date: Feb 2012
Location: Louisiana
Quote:
Originally Posted by ATTACK View Post
Yes.
So just by flashing the KK firmware in RSD without any changes to the xml? Sorry for the noob questions, I realize how easy this phone can be bricked and I want to avoid it.
Droid Razr M (CM11.0 4.4.3)
Nook Tablet (AOKP 4.4.2)
Nexus 5 (AOSP 4.4.3)
 
ATTACK
Old
#9  
ATTACK's Avatar
Recognized Themer
Thanks Meter 1412
Posts: 1,045
Join Date: Jan 2012

 
DONATE TO ME
Quote:
Originally Posted by TheForceUnleashed View Post
So just by flashing the KK firmware in RSD without any changes to the xml? Sorry for the noob questions, I realize how easy this phone can be bricked and I want to avoid it.
I see why you would need to. It would be just like restoring stock firmware via RSD Lite.
~$ locate Dev-Host
/public/ATTACK/myfiles/d-h.st
 
jrk190
Old
#10  
jrk190's Avatar
Senior Member
Thanks Meter 69
Posts: 787
Join Date: Sep 2012
Location: McLeansville
When I try to flash this, I get Failure on 2/20, sbl1
I've owned a lot of phones. Too many, probably.
So I'm just holding out for a new phone, hanging in there with my Galaxy Nexus (Toro) and Nexus 7 (Grouper).
Feel free to buy a poor college student a new phone... Like, any phone...
Please?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes