Post Reply

[Q] XT907 Problems with Clockwork Recovery installing Cyanogenmod

OP Sporty824

30th August 2014, 03:20 AM   |  #1  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
I recently rooted my Droid Razr M XT907 and have had nothing but problems. Before rooting, I was on 4.4.2. I used the Towelroot app to root my phone, Root Checker to verify root, and Motopocalypse to unlock my bootloader. I tried to flash a custom recovery and I could not boot into recovery. I also tried to flash a new logo to get rid of the bootloader unlocked warning screen. Apparently I flashed a corrupted file because it caused my phone not to turn on right and I had to go straight to the boot menu and AP fastboot to flash stock 4.4.2 for my phone. I then proceeded to root my phone again, and start over(except I didn't have to unlock my bootloader again). After another few hours, I finally got CWM Recovery v6.0.4.8 installed on my phone. I tried to wipe data/factory reset and it did this:
- - Wiping data. . .
Formatting /data. . .
Error mounting /data!
Skipping format. . .
Formatting /cache. . .
Formatting /sd-ext. . .
E: unkown volume for path [/sd-ext]
Formatting /sdcard/.android_secure!
Skipping format. . .
Data wipe complete.

I am pretty sure that it did not format. I tried goint to mounts and storage menu and mounting /data there and it said:
Error mounting /data!

Thinking it was not a big deal, I proceeded to try and install zip from the external sd card. I went to Install Zip > Choose zip from /storage/sdcard1 and selected the zip I had on there called "cm- 11 -20140218-NIGHTLY-xt907.zip" and this is what it gave me:
- - Installing: /storage/sdcard1/cm- 11-20140218-NIGHTLY-xt907.zip
Finding update package. . .
Opening update package. . .
Installing update. . .
This package is for "xt925, xt926, xt907, vanquish_u, vanquish, scorpion_mini, mb886, qinara, asanti, asanti_c, xt897, xt897c" devices; this is a " ".
E: Error in /storage/sdcard1/cm- 11 -20140218-NIGHTLY-xt907.xip
(Status 7)
Installation aborted

At this point, all i want to do is be able to flash Cyanogenmod on my phone. Is there any way to fix the mounting /data problem? Is there just an easier way to install Cyanogenmod at this point? Any help would be greatly appreciated.
30th August 2014, 08:32 AM   |  #2  
AndyYan's Avatar
Senior Member
Flag Beijing
Thanks Meter: 888
 
2,159 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by Sporty824

I recently rooted my Droid Razr M XT907 and have had nothing but problems. Before rooting, I was on 4.4.2. I used the Towelroot app to root my phone, Root Checker to verify root, and Motopocalypse to unlock my bootloader. I tried to flash a custom recovery and I could not boot into recovery. I also tried to flash a new logo to get rid of the bootloader unlocked warning screen. Apparently I flashed a corrupted file because it caused my phone not to turn on right and I had to go straight to the boot menu and AP fastboot to flash stock 4.4.2 for my phone. I then proceeded to root my phone again, and start over(except I didn't have to unlock my bootloader again). After another few hours, I finally got CWM Recovery v6.0.4.8 installed on my phone. I tried to wipe data/factory reset and it did this:
- - Wiping data. . .
Formatting /data. . .
Error mounting /data!
Skipping format. . .
Formatting /cache. . .
Formatting /sd-ext. . .
E: unkown volume for path [/sd-ext]
Formatting /sdcard/.android_secure!
Skipping format. . .
Data wipe complete.

I am pretty sure that it did not format. I tried goint to mounts and storage menu and mounting /data there and it said:
Error mounting /data!

Thinking it was not a big deal, I proceeded to try and install zip from the external sd card. I went to Install Zip > Choose zip from /storage/sdcard1 and selected the zip I had on there called "cm- 11 -20140218-NIGHTLY-xt907.zip" and this is what it gave me:
- - Installing: /storage/sdcard1/cm- 11-20140218-NIGHTLY-xt907.zip
Finding update package. . .
Opening update package. . .
Installing update. . .
This package is for "xt925, xt926, xt907, vanquish_u, vanquish, scorpion_mini, mb886, qinara, asanti, asanti_c, xt897, xt897c" devices; this is a " ".
E: Error in /storage/sdcard1/cm- 11 -20140218-NIGHTLY-xt907.xip
(Status 7)
Installation aborted

At this point, all i want to do is be able to flash Cyanogenmod on my phone. Is there any way to fix the mounting /data problem? Is there just an easier way to install Cyanogenmod at this point? Any help would be greatly appreciated.

I'm not techy so don't know what exactly is going on, but I advise dealing with the mount problems before you proceed to flashing CM. If flashing stock again via RSD won't fix this, I assume your /data partition is faulty.
30th August 2014, 01:20 PM   |  #3  
ATTACK's Avatar
Recognized Themer
Thanks Meter: 1,667
 
1,250 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Sporty824

I recently rooted my Droid Razr M XT907 and have had nothing but problems. Before rooting, I was on 4.4.2. I used the Towelroot app to root my phone, Root Checker to verify root, and Motopocalypse to unlock my bootloader. I tried to flash a custom recovery and I could not boot into recovery. I also tried to flash a new logo to get rid of the bootloader unlocked warning screen. Apparently I flashed a corrupted file because it caused my phone not to turn on right and I had to go straight to the boot menu and AP fastboot to flash stock 4.4.2 for my phone

. I then proceeded to root my phone again, and start over(except I didn't have to unlock my bootloader again). After another few hours, I finally got CWM Recovery v6.0.4.8 installed on my phone. I tried to wipe data/factory reset and it did this:
- - Wiping data. . .
Formatting /data. . .
Error mounting /data!
Skipping format. . .
Formatting /cache. . .
Formatting /sd-ext. . .
E: unkown volume for path [/sd-ext]
Formatting /sdcard/.android_secure!
Skipping format. . .
Data wipe complete.

I am pretty sure that it did not format. I tried goint to mounts and storage menu and mounting /data there and it said:
Error mounting /data!

Thinking it was not a big deal, I proceeded to try and install zip from the external sd card. I went to Install Zip > Choose zip from /storage/sdcard1 and selected the zip I had on there called "cm- 11 -20140218-NIGHTLY-xt907.zip" and this is what it gave me:
- - Installing: /storage/sdcard1/cm- 11-20140218-NIGHTLY-xt907.zip
Finding update package. . .
Opening update package. . .
Installing update. . .
This package is for "xt925, xt926, xt907, vanquish_u, vanquish, scorpion_mini, mb886, qinara, asanti, asanti_c, xt897, xt897c" devices; this is a " ".
E: Error in /storage/sdcard1/cm- 11 -20140218-NIGHTLY-xt907.xip
(Status 7)
Installation aborted

At this point, all i want to do is be able to flash Cyanogenmod on my phone. Is there any way to fix the mounting /data problem? Is there just an easier way to install Cyanogenmod at this point? Any help would be greatly appreciated.

First, you need to update your recovery. > http://goo.gl/7pDg47

Second, your trying to flash an outdated ROM that wont work on the updated KK bootloader. Go to the CM thread and download the correct version for your device. > http://goo.gl/Jx8EOu

Custom boot logos > http://goo.gl/fgOCNb
Last edited by ATTACK; 30th August 2014 at 02:42 PM.
The Following 2 Users Say Thank You to ATTACK For This Useful Post: [ View ]
30th August 2014, 09:32 PM   |  #4  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
@ATTACK

Should I stick with CWM or switch to TWRP? Or is it just personal preference? Also, should I reflash stock and try again or just start reflashing the recovery and new ROM? The logo is lowest on my priority list btw.

Edit: So wait, is the Razr M XT907 a part of the Moto_MSM8960 devices? I could just install that like I would the other one?
Last edited by Sporty824; 30th August 2014 at 09:41 PM.
30th August 2014, 10:34 PM   |  #5  
ATTACK's Avatar
Recognized Themer
Thanks Meter: 1,667
 
1,250 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Sporty824

@ATTACK

Should I stick with CWM or switch to TWRP? Or is it just personal preference? Also, should I reflash stock and try again or just start reflashing the recovery and new ROM? The logo is lowest on my priority list btw.

Edit: So wait, is the Razr M XT907 a part of the Moto_MSM8960 devices? I could just install that like I would the other one?

Yup, it's personal preference. I prefer TWRP but just use whatever your comfortable with.

I see no need to go stock, just flash the new recovery then the ROM. And yes, all the moto_msm8960 devices have been unified, this includes the xt907. Just make sure you use the KK bootloader compatible version.
The Following User Says Thank You to ATTACK For This Useful Post: [ View ]
31st August 2014, 01:01 AM   |  #6  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by ATTACK

Yup, it's personal preference. I prefer TWRP but just use whatever your comfortable with.

I see no need to go stock, just flash the new recovery then the ROM. And yes, all the moto_msm8960 devices have been unified, this includes the xt907. Just make sure you use the KK bootloader compatible version.

OK. I downloaded a new custom recovery (I switched to TWRP since is was all touch based and I somehow broke the volume buttons on my last android). I then downloaded the newest CM and flashed it and the GAPPS. Everything works great. I even flashed a custom logo (the batman one). Thank you.
The Following User Says Thank You to Sporty824 For This Useful Post: [ View ]
31st August 2014, 03:52 AM   |  #7  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
OK, someone please help, got everything else working, except data. I can't get mobile data working. I just want to know if there is anything I can do.
1st September 2014, 03:31 PM   |  #8  
ATTACK's Avatar
Recognized Themer
Thanks Meter: 1,667
 
1,250 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Sporty824

OK, someone please help, got everything else working, except data. I can't get mobile data working. I just want to know if there is anything I can do.

Ummm.... try RSDing back to stock and see if your data comes back.
The Following User Says Thank You to ATTACK For This Useful Post: [ View ]
6th September 2014, 07:22 PM   |  #9  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by ATTACK

Ummm.... try RSDing back to stock and see if your data comes back.

Flashed back to stock. Still no data. Any other suggestions?

Edit: Nevermind, started working on stock after I flashed a new radio and reflashed stock. Going to try to install cm when I get home and hope it works
Last edited by Sporty824; 7th September 2014 at 03:16 AM.
8th September 2014, 02:50 AM   |  #10  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Aug 2014
More
I reflashed stock, and data worked. I flashed CM11, and it didn't. I reflashed stock, and it worked again. I searched the problem online, again. I somehow found a site that I missed when I searched it the first few times. The site provided a fix that involved flashing cm11, gapps, and another zip. I tried it and it worked. For anyone who is having the same or similar problem, the link is below. Thank you ATTACK for all of the help and Deante Flood for making the zip that I flashed that made the data work again.

https://help.ting.com/entries/423580...d-4-4-Kit-Kat-

The Following User Says Thank You to Sporty824 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes