Default Hardware boot problem.

Hi,

So this is the problem,

Screw somehow couldn't screw in with battery installed but it was able to do so with battery removed from phone.
I removed screw again. After some time when I screwed it in again, it just couldn't come out, just kept spinning in place.


So I, just out of boredom went to instal battery with - screwed in and + connector just placed over screw.
It worked for a while but wasn't able to display battery on stock 4.1.2 and custom 4.3, only question mark was displayed.
I have CID error so I boot over BMM.


When battery drained it would not boot anymore. After that, when connected to charger it would display ? again, and only few times it allowed me to boot, but unexpectedly shuts down while still connected.

After that it wont boot again when connected to charger or make any reaction when it's off the charger.
When I connect it to charger while it's shut down, normal process would be CID error-Orange led flash-Battery status, and now it is the same, accept the battery status which is ?

Now if I disconnect it when charging process just started it would hold till end with only charge coming from battery.
I've also tried charging with wires with no result.

Thats about it, I hope you will be able to help.