Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,836 Members 42,047 Now Online
XDA Developers Android and Mobile Development Forum

[HOW TO] Downgrade from 19.6.3 to 19.5.3 RSD Lite or Fastboot

Tip us?
 
CurbThePain
Old
(Last edited by CurbThePain; 17th August 2014 at 06:42 PM.)
#1  
CurbThePain's Avatar
Member - OP
Thanks Meter 16
Posts: 69
Join Date: Feb 2013
Location: Ixonia
Angry [HOW TO] Downgrade from 19.6.3 to 19.5.3 RSD Lite or Fastboot

Alright so to start off here's the usual, I'm not responsible if you brick your phone or if your computer starts spitting corrosive acid at you, you know the general anything and everything that can happen on this planet.

So basically I have two files I'm uploading right now. The flash.zip that you have to download and the RSD lite zip that is optional.

You need to download the flash.zip or both and extract them and install RSD. After doing so you'll have to put your phone into fastboot by powering it off and holding the power button and vol - key together until it pops up in AP flash. (YOU DON'T NEED TO DO THIS IF YOUR USING THE LAUNCH.bat)

After all of that you need to plug in your phone to your desktop and assuming you have all the drivers installed you need to either open RSD and select the xml in the folder you extracted from the flash.zip and select your phone and start the flashing process.

Now if your phone is not recognized by RSD you need to run the LAUNCH.bat and it will do the whole process in about 5-15 minutes (rough estimate)

After everything is done your phone will reboot and your on 19.5.3 and can root your phone permanently and gain system r/w permissions with my other thread HERE.

Credits:
Credit for the downgrade through fastboot go to myself and Google for fastboot of course.
Credits for the other stuff in the other thread are in the link up above.

Download Section:
FLASH.zip
RSD 5.7

Devices:
  • Droid Maxx
    • Service Provider: At&t Prepaid
    • Rom: Stock 4.4.4
    • Launcher: Trebuchet
    • Memory: 2Gb
  • Samsung Galaxy Tab 4 7.0 FOR SALE (Just PM me)
    • Rom: Stock
    • Launcher: Touch Wiz UX
    • Android Version: 4.4.2
    • Memory: ~1.5Gb
  • Zte Awe
    • Rom: Carbon Rom Beta 4.4.4
    • Theme: Stock
    • Launcher: Trebuchet
    • Android Version: 4.4.4
    • Memory: 836 MB
    • CPU: ARMv7 Processor rev 4 (v71)
    • SELinux status: Permissive
 
Jay_P11
Old
#2  
Member
Thanks Meter 4
Posts: 35
Join Date: Jan 2013
Is this for unlocked bootloaders only? I just tried it and it keeps failing because I get this:

downgraded security version
update gpt_main version failed
preflash validation failed for GPT


RSD Lite says:

Failed flashing process. 2/17 flash partition "gpt.bin"

Really hope this isn't for unlocked users only cause I just wiped my phone for this to test it and root
Current daily driver: LG G2 VS890 - Mahdi ROM
 
CurbThePain
Old
#3  
CurbThePain's Avatar
Member - OP
Thanks Meter 16
Posts: 69
Join Date: Feb 2013
Location: Ixonia
Quote:
Originally Posted by Jay_P11 View Post
Is this for unlocked bootloaders only? I just tried it and it keeps failing because I get this:

downgraded security version
update gpt_main version failed
preflash validation failed for GPT


RSD Lite says:

Failed flashing process. 2/17 flash partition "gpt.bin"

Really hope this isn't for unlocked users only cause I just wiped my phone for this to test it and root
Its for the non-dev Droid Maxx/Droid Ultra's with locked bootloaders. It sounds like your on a os lower than 4.4 or higher than 4.4. Can you give me your system specs? (Android version, System version, and phone model)

Devices:
  • Droid Maxx
    • Service Provider: At&t Prepaid
    • Rom: Stock 4.4.4
    • Launcher: Trebuchet
    • Memory: 2Gb
  • Samsung Galaxy Tab 4 7.0 FOR SALE (Just PM me)
    • Rom: Stock
    • Launcher: Touch Wiz UX
    • Android Version: 4.4.2
    • Memory: ~1.5Gb
  • Zte Awe
    • Rom: Carbon Rom Beta 4.4.4
    • Theme: Stock
    • Launcher: Trebuchet
    • Android Version: 4.4.4
    • Memory: 836 MB
    • CPU: ARMv7 Processor rev 4 (v71)
    • SELinux status: Permissive
 
Jay_P11
Old
#4  
Member
Thanks Meter 4
Posts: 35
Join Date: Jan 2013
Quote:
Originally Posted by TheOriginalist View Post
Its for the non-dev Droid Maxx/Droid Ultra's with locked bootloaders. It sounds like your on a os lower than 4.4 or higher than 4.4. Can you give me your system specs? (Android version, System version, and phone model)
Android 4.4.4
Build SU4.21
System Version 21.11.21.obake_verizon.Verizon.en.US
The update said it was 19.6.3 when I downloaded it so now I'm really confused
Current daily driver: LG G2 VS890 - Mahdi ROM
 
CurbThePain
Old
#5  
CurbThePain's Avatar
Member - OP
Thanks Meter 16
Posts: 69
Join Date: Feb 2013
Location: Ixonia
Quote:
Originally Posted by Jay_P11 View Post
Android 4.4.4
Build SU4.21
System Version 21.11.21.obake_verizon.Verizon.en.US
The update said it was 19.6.3 when I downloaded it so now I'm really confused
Yeah it said that probably from a previous download or something whats important is that you didnt brick your device. Can you boot?

Devices:
  • Droid Maxx
    • Service Provider: At&t Prepaid
    • Rom: Stock 4.4.4
    • Launcher: Trebuchet
    • Memory: 2Gb
  • Samsung Galaxy Tab 4 7.0 FOR SALE (Just PM me)
    • Rom: Stock
    • Launcher: Touch Wiz UX
    • Android Version: 4.4.2
    • Memory: ~1.5Gb
  • Zte Awe
    • Rom: Carbon Rom Beta 4.4.4
    • Theme: Stock
    • Launcher: Trebuchet
    • Android Version: 4.4.4
    • Memory: 836 MB
    • CPU: ARMv7 Processor rev 4 (v71)
    • SELinux status: Permissive
 
Jay_P11
Old
#6  
Member
Thanks Meter 4
Posts: 35
Join Date: Jan 2013
Quote:
Originally Posted by TheOriginalist View Post
Yeah it said that probably from a previous download or something whats important is that you didnt brick your device. Can you boot?
All is well. I backed up my pics and stuff as I always do before trying something like this, so nothing major was lost. Just gotta re-install all my apps cause google backup somehow chose to not help me in my time of need > but I guess the version I came from was what it said was 19.6.3 and I never bothered to double check before trying anything. Man would it be great if this worked on 4.4.4 though. Have you or anyone else tried the root method on 4.4.4? If not (unless you're sure it won't work) I'm willing to try the root process.
Current daily driver: LG G2 VS890 - Mahdi ROM
 
CurbThePain
Old
#7  
CurbThePain's Avatar
Member - OP
Thanks Meter 16
Posts: 69
Join Date: Feb 2013
Location: Ixonia
Quote:
Originally Posted by Jay_P11 View Post
All is well. I backed up my pics and stuff as I always do before trying something like this, so nothing major was lost. Just gotta re-install all my apps cause google backup somehow chose to not help me in my time of need > but I guess the version I came from was what it said was 19.6.3 and I never bothered to double check before trying anything. Man would it be great if this worked on 4.4.4 though. Have you or anyone else tried the root method on 4.4.4? If not (unless you're sure it won't work) I'm willing to try the root process.
No but I've tried my own exploits on other Android versions like 4.4 and 4.2.2 on this phone. I just wont risk updating to 4.4.4.

Devices:
  • Droid Maxx
    • Service Provider: At&t Prepaid
    • Rom: Stock 4.4.4
    • Launcher: Trebuchet
    • Memory: 2Gb
  • Samsung Galaxy Tab 4 7.0 FOR SALE (Just PM me)
    • Rom: Stock
    • Launcher: Touch Wiz UX
    • Android Version: 4.4.2
    • Memory: ~1.5Gb
  • Zte Awe
    • Rom: Carbon Rom Beta 4.4.4
    • Theme: Stock
    • Launcher: Trebuchet
    • Android Version: 4.4.4
    • Memory: 836 MB
    • CPU: ARMv7 Processor rev 4 (v71)
    • SELinux status: Permissive
 
Topsnake
Old
#8  
Topsnake's Avatar
Senior Member
Thanks Meter 451
Posts: 843
Join Date: Jan 2011

 
DONATE TO ME
Thread is not needed. The simple process would be to simply download the fxz from the reputable sbfdevelopers and flash. Nothing else is needed. Again repost.

Moral of the story, SEARCH BEFORE POSTING! Chances are it has been asked several times.
The Following User Says Thank You to Topsnake For This Useful Post: [ Click to Expand ]
 
CurbThePain
Old
#9  
CurbThePain's Avatar
Member - OP
Thanks Meter 16
Posts: 69
Join Date: Feb 2013
Location: Ixonia
Quote:
Originally Posted by Topsnake View Post
Thread is not needed. The simple process would be to simply download the fxz from the reputable sbfdevelopers and flash. Nothing else is needed. Again repost.
Again I am just trying to simplify things for people. Especially if they have issues with RSD Lite.

Devices:
  • Droid Maxx
    • Service Provider: At&t Prepaid
    • Rom: Stock 4.4.4
    • Launcher: Trebuchet
    • Memory: 2Gb
  • Samsung Galaxy Tab 4 7.0 FOR SALE (Just PM me)
    • Rom: Stock
    • Launcher: Touch Wiz UX
    • Android Version: 4.4.2
    • Memory: ~1.5Gb
  • Zte Awe
    • Rom: Carbon Rom Beta 4.4.4
    • Theme: Stock
    • Launcher: Trebuchet
    • Android Version: 4.4.4
    • Memory: 836 MB
    • CPU: ARMv7 Processor rev 4 (v71)
    • SELinux status: Permissive

The Following User Says Thank You to CurbThePain For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Android M Mentions Spotted in Android Code Review

While we are still waiting for Android L to be officially released, the first mentions of … more

Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more

MediaTek Continues Steps Towards Being Developer-Friendly

Not too long ago MediaTek was very closed off towards the mobile developer … more