FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

Touchless Control

70 posts
Thanks Meter: 5
 
By tombaldwin6, Member on 23rd July 2014, 03:05 AM
Post Reply Subscribe to Thread Email Thread
19th September 2014, 12:37 PM |#11  
Member
Thanks Meter: 22
 
More
Smile
Same issue here. Been a week since I FDR'd (NOT rooted or unlocked). The apps restored, touchless control no longer allows to register voice (does not recognize sound ONLY for Touchless Control).

Saw that Touchless Control has been updated to "Moto Voice",

Uninstalled Moto Voice to return to previous version. No luck. Again updated to Moto Voice.

Wipe Cache Partition, no luck.

I've installed Open Mic+, which works for the most part (never got it to work from lock screen)

Stopped Open Mic+.

I then went in Language & input ---> Google voice typing settings (or Voice Search), disabled/re-enabled Speech Output. Clicked on "Ok Google Detection" and did the standard Google Now/OK Google setup again.

Went back to Touchless Control and this time it recognized my voice and allowed me to setup Touchless Control and all is working again.

Although the new "Moto Voice" on the "1st Gen [2013] Ultra/Maxx etc.., you cannot customize the "OK Google Now" at this time (coming feature for Gen 1's).

Rebooting now to ensure operation. Will updated/verify 'fix' in a moment.

Upon restart, my Open Mic+ restarted, and the "OK Google Now" was not working. Stopped the Open Mic+ and touchless control working again. Went in and re-trained to verify. Unintalling Open Mic+ and rebooting now.

Now again working 100%, now just awaiting Moto Voice update to allow additional features for 1st gen's.
Last edited by iamtek7; 19th September 2014 at 12:53 PM. Reason: Updated info
The Following User Says Thank You to iamtek7 For This Useful Post: [ View ]
 
 
19th September 2014, 02:37 PM |#12  
Member
Flag Temecula, Ca
Thanks Meter: 14
 
More
i have got mine working gain too. I still haven't reinstalled everything though. I will reinstall x tether this weekend. I am hoping that it isn't cuseing any problems. Can't imagine why it would, but we will see. Do you guys have it installed?
19th September 2014, 04:17 PM |#13  
Senior Member
Thanks Meter: 335
 
More
Did you happen to open the Google app, scroll to the bottom, tap the three dot menu control on the bottom right, tap settings, voice, OK Google detection, and turn off the setting "On any screen"?

If that is on, I think it block touchless controls, maddeningly. I know it stops the Assist driving feature from being able to capture voice when it prompts you.
19th September 2014, 06:43 PM |#14  
Member
Thanks Meter: 22
 
More
Quote:
Originally Posted by doogald

Did you happen to open the Google app, scroll to the bottom, tap the three dot menu control on the bottom right, tap settings, voice, OK Google detection, and turn off the setting "On any screen"?

If that is on, I think it block touchless controls, maddeningly. I know it stops the Assist driving feature from being able to capture voice when it prompts you.

I set "on any screen" option and touchless controls does work from any screen, needing only "OK Google".

I am not driving now but will check Assist in about 2 hours.
19th September 2014, 08:34 PM |#15  
Senior Member
Thanks Meter: 335
 
More
Quote:
Originally Posted by iamtek7

I set "on any screen" option and touchless controls does work from any screen, needing only "OK Google".

I am not driving now but will check Assist in about 2 hours.

I don't think that's touchless controls - I think that's the Google search app listening and responding to ok Google , and, with that setting on, that's probably why you couldn't train in the Touchless controls settings (though I haven't tested that myself, since my phone is already trained.)

I know it's a subtle difference, but Touchless controls is a front end to google search most of the time, though sometimes it does its own thing (ok Google now, what's up?)

I do know that the any screen setting screws up some other things, like preventing the camera app from capturing video (because the microphone is in use).
Last edited by doogald; 19th September 2014 at 09:57 PM.
21st September 2014, 09:01 PM |#16  
bendrum30's Avatar
Member
Thanks Meter: 7
 
More
I'm all set now. If this is still an issue for anyone, let me know.

Sent from my XT1080 Developer Edition using Tapatalk
Last edited by bendrum30; 24th September 2014 at 03:22 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes