FORUMS
Post Reply Subscribe to Thread Email Thread

[Q] Unable to install Cyanogenmod as custom Rom with CWM

2nd September 2014, 02:48 PM |#1  
OP Junior Member
Thanks Meter: 1
 
More
Hi folks,

I'm a fairphone 1 1st edition (repartitioned with 1.6 update) owner and i have been eagerly waiting for cyanogenmod for quite a while. I saw this thread: http://forum.xda-developers.com/show....php?t=2615613 and followed the installation instructions.

Procedure:
1) [Install MTK 6589 driver][1]
2) Install + Open up [MTK Droid Root & Tools v. 2.5.3][2]
3) Root phone in MTK Droid Root & Tools
4) Backup phone with MTK Droid Root & Tools
5) Download [Recovery Image][3] (KitKat) and follow [installation instructions][4]:

a) copy the recovery to the device: adb push cwm-fp1-kk.0.1.img /storage/sdcard1

b) adb into device: adb shell

c) flash to recovery: dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img of=/dev/recovery
6) Reboot into Recovery with [Rom Manager 6.6.3.7 ][5]
7) Select [zip file][6] from sd card and install

Error message: Can't install this package on top of incompatible data. Please try another package or run a factory reset. E: Error in /storage/sdcard1/cm-11_FP1-ota-UNOFFICIAL-FULLOFBUGS-0.1.zip
(Status 7)
Installation aborted.

I also deleted the assert line in the updater-script file and updated the zip file, as during the installation Error Status 7 showed up (see this [site][7]).
Still installation aborts, this time no error message is given. Any ideas? Thanks in advance!


[1]: http://vondroid.com/resources/mediat.../#.VAW0VUQdHT8
[2]: http://samclone.blogspot.de/2013/11/...tools-248.html
[3]: http://click.xda-developers.com/api/...fp1-kk.0.1.img
[4]: http://forum.xda-developers.com/show....php?t=2615613
[5]: https://play.google.com/store/apps/d...tta.rommanager
[6]: http://forum.xda-developers.com/fair...itkat-t2862874
[7]: http://highonandroid.com/android-rom...ooted-android/
Last edited by madde-; 2nd September 2014 at 02:53 PM.
 
 
3rd September 2014, 07:03 AM |#2  
Member
Flag Amsterdam
Thanks Meter: 135
 
More
Quote:
Originally Posted by madde-

Error message: Can't install this package on top of incompatible data. Please try another package or run a factory reset. E: Error in /storage/sdcard1/cm-11_FP1-ota-UNOFFICIAL-FULLOFBUGS-0.1.zip

I had the same error message try first formatting the system partition.
3rd September 2014, 07:48 AM |#3  
Recognized Developer
Thanks Meter: 2,832
 
More
I think that you need to "wipe data" in cwm before flashing when you install for the first time.

Chris
The Following User Says Thank You to chrmhoffmann For This Useful Post: [ View ]
3rd September 2014, 08:46 AM |#4  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by chrmhoffmann

I think that you need to "wipe data" in cwm before flashing when you install for the first time.

Chris

works like a charm!

Thank you very much for your help and your great work! Any way to flattr you or send you bitcoin donations for your work?
Last edited by madde-; 4th September 2014 at 04:17 PM.
2nd October 2014, 06:55 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Hi everybody!
I'm new here.
I have just installed cyanogen mod on my FP1...very happy with it! thanks Chris!
Last edited by superfantafedera; 2nd October 2014 at 07:55 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes