[ROM][UNOFFICIAL][WIP] Cyanogenmod 11 (4.4.4 - kitkat) for fairphone FP1

757 posts
Thanks Meter: 2,970
By chrmhoffmann, Recognized Developer on 30th August 2014, 07:14 PM
Post Reply Subscribe to Thread Email Thread
17th April 2015, 11:58 AM |#21  
Thanks Meter: 1
Originally Posted by dbrgn

I think I would contribute to that

So would I! Now it is pretty much official, that the makers of Fairphone will not be providing any new android versions (for the time being, they don't even ensure essential security updates, such as fixing the UXSS vulnerability). So clearly, there is no other option to ever get a newer Android onto the FP1. Who could take the lead on this? Also, is there any indication that @chrmhoffmann might be interested?
Last edited by yahya69; 17th April 2015 at 11:59 AM. Reason: wrong user name
17th April 2015, 08:20 PM |#22  
OP Recognized Developer
Thanks Meter: 2,970

Without MTK sources, you won't be able to make a full functioning rom.

Anyway, I unfortunately don't have the time.

My advice, buy a new phone and make sure it is supported by cyanogen.

The Following User Says Thank You to chrmhoffmann For This Useful Post: [ View ]
17th April 2015, 10:18 PM |#23  
Junior Member
Thanks Meter: 5
Does anyone know what requirements does MTK have? Did they want money or did you have to sign a NDL?
7th May 2015, 10:08 PM |#24  
Senior Member
Thanks Meter: 47
Wait, didn't you build this rom with the kernel that you compiled yourself? You even linked to a github page for that. Which sources are missing then? I'm confused
11th September 2015, 10:26 PM |#25  
Junior Member
Thanks Meter: 3
I'm struggling to build CM11 (reason: latest CM11.0 stable should fix stagefright bug).
Problem seems to be building the custom kernel. So far I have tried to build it directly following this building guide ( resulting in:

-D"KBUILD_MODNAME=KBUILD_STR(file_table)" -c -o fs/file_table.o fs/file_table.c
fs/file_table.c: In function 'get_empty_filp':
fs/file_table.c:36:20: error: inlining failed in call to always_inline 'fd_show_open_files': function body not available
fs/file_table.c:160:36: error: called from here
scripts/ recipe for target 'fs/file_table.o' failed
make[1]: *** [fs/file_table.o] Error 1
Makefile:967: recipe for target 'fs' failed
make: *** [fs] Error 2

I tried building Cyanogenmod with this local_manifest ( With following commands:
repo init -u -b cm-11.0
repo sync
adb connect [...]
cd fp/FP1
. build/
brunch FP1

Build fails with:

find: `bootable/recovery/res-540': No such file or directory No private recovery resources for TARGET_DEVICE FP1 build/core/tasks/ ************************************************** ******** build/core/tasks/ * Kernel source found, but no configuration was defined * build/core/tasks/ * Please add the TARGET_KERNEL_CONFIG variable to your * build/core/tasks/ * file * build/core/tasks/ ************************************************** ******** Install: /home/martin/android/system/out/host/linux-x86/bin/mkbootimg Install: /home/martin/android/system/out/host/linux-x86/bin/mkbootfs Install: /home/martin/android/system/out/host/linux-x86/bin/checkpolicy Install: /home/martin/android/system/out/host/linux-x86/bin/checkfc Install: /home/martin/android/system/out/host/linux-x86/bin/clang-tblgen

Setting TARGET_KERNEL_CONFIG := ../../../kernel/fp/FP1/mediatek/config/ahong89_wet_jb2/configs/ in device/fp/FP1/ results in:

make -C kernel/fp/FP1 O=/home/martin/android/system/out/target/product/FP1/obj/KERNEL_OBJ ARCH=arm CROSS_COMPILE=" /home/martin/android/system/prebuilts/gcc/linux-x86/arm/arm-eabi-4.7/bin/arm-eabi-" headers_install
make[1]: Entering directory '/home/martin/android/system/kernel/fp/FP1'
make[1]: *** No rule to make target 'headers_install'. Stop.
make[1]: Leaving directory '/home/martin/android/system/kernel/fp/FP1'
build/core/tasks/ recipe for target '/home/martin/android/system/out/target/product/FP1/obj/KERNEL_OBJ/usr' failed
make: *** [/home/martin/android/system/out/target/product/FP1/obj/KERNEL_OBJ/usr] Error 2
make: *** Waiting for unfinished jobs....

Any idea how to build succesful? Where have I gone wrong in this?
The Following User Says Thank You to madde- For This Useful Post: [ View ]
26th September 2015, 07:09 AM |#26  
Junior Member
Thanks Meter: 1
Some light at the end of the tunnel:
30th October 2015, 08:48 PM |#27  
Junior Member
Thanks Meter: 4
Can you please reupload this and the recovery?
8th November 2015, 01:35 AM |#28  
OP Recognized Developer
Thanks Meter: 2,970
Maybe this is of interest:
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes