Sony Xperia Z3 Lollipop Framework Ported to CM12

Android 5.0 for Xperia has a unique look and feel. You don’t have to get a Sony … more

Do You Use Recents as a Task Switcher?

Google introduced a revamped Recents interface with Lollipop in the hopes of making it easier for … more

YU Yureka All-in-One ToolBox (CM12S Only)

This packed toolbox by XDA Senior Member gohel.vishal makes many useful tweaks … more

Sony Xperia Z4 Forum Now Available

Sony’s Xperia line has seen plenty of development on XDA, and now that the Xperia Z4 has been … more
Post Reply Subscribe to Thread Email Thread

[REF] LVM Partition Remapping

25th January 2015, 10:07 PM |#121  
Senior Member
Thanks Meter: 9
 
148 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by Entropy512

I've confirmed 2.8.0.1 and 2.8.3.0 work

2.8.4.0 SHOULD work, I'll try it out this weekend to figure out why.

Hey entropy, can you confirm that 2.8.4.0 is working as well? (;
Last edited by znarf2369; 26th January 2015 at 07:51 PM.
 
 
30th January 2015, 12:31 AM |#122  
BigBrother1984's Avatar
Recognized Developer
Flag Rome
Thanks Meter: 6,063
 
1,443 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Quote:
Originally Posted by maxwen

It will not work with selinux enforced unless you add a few other changes
This is wip

https://gerrit.omnirom.org/11178
https://gerrit.omnirom.org/11277

Quote:
Originally Posted by ayysir

thanks however, even with making selinux permissive and adding seliux permissions. Still can not get device to boot

wondering if my implementation is wrong somehow

last_kmesg:

Code:
[    8.008765] SELinux: Could not set context for /cache:  Read-only file system
[    8.009439] SELinux: Could not set context for /data:  Read-only file system
[    8.019378] SELinux: Could not set context for /data:  Read-only file system
[    8.019660] SELinux: Could not set context for /data/lvm:  Read-only file system
[    8.019809] SELinux: Could not set context for /data/lvm/backup:  Read-only file system
[    8.019951] SELinux: Could not set context for /data/lvm/backup/lvpool:  Read-only file system
[    8.020030] SELinux: Could not set context for /data/lvm/archive:  Read-only file system
[    8.020179] SELinux: Could not set context for /data/lvm/archive/lvpool_00000-926546556.vg:  Read-only file system
[    8.020285] SELinux: Could not set context for /data/lvm/lock:  Read-only file system
[    8.021577] SELinux:  Could not stat /data/misc/sensors: No such file or directory.

Take a look here now i leaved a comment with a commit https://gerrit.omnirom.org/#/c/11277/
20th March 2015, 11:15 PM |#123  
Member
Flag Valencia
Thanks Meter: 7
 
53 posts
Join Date:Joined: Mar 2010
More
I've been using LVM with Omni for months, first with 4.4 and since some weeks with 5.0.2 test builds. Today I've tried to test 5.1 and now I'm unable to configure LVM. After install 5.1 test build I can't get phone signal; wifi was ok, but phone doesn't. So I ask for clues and @maxwen answered me that I was using wrong firmware/modem. I tried to install the right one and due to a terrible mistake I flashed a wrong modem, bricking my phone. Impossible to boot in system or recovery, only in fastboot. Using the unbrick tool I've been able to restore my phone, but now I can't configure LVM. I've tried with several TWRP versions downloaded from official TWRP site and the twrp_find7_lvm_09012014.img provided in the LVM post, but I can see several messages saying "Unable to mount 'Internal_sd'" and then "Failed".
Is there something I can do?
Thanks for your help.
21st March 2015, 10:07 PM |#124  
Member
Flag Valencia
Thanks Meter: 7
 
53 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by javier.pc

I've been using LVM with Omni for months, first with 4.4 and since some weeks with 5.0.2 test builds. Today I've tried to test 5.1 and now I'm unable to configure LVM. After install 5.1 test build I can't get phone signal; wifi was ok, but phone doesn't. So I ask for clues and @maxwen answered me that I was using wrong firmware/modem. I tried to install the right one and due to a terrible mistake I flashed a wrong modem, bricking my phone. Impossible to boot in system or recovery, only in fastboot. Using the unbrick tool I've been able to restore my phone, but now I can't configure LVM. I've tried with several TWRP versions downloaded from official TWRP site and the twrp_find7_lvm_09012014.img provided in the LVM post, but I can see several messages saying "Unable to mount 'Internal_sd'" and then "Failed".
Is there something I can do?
Thanks for your help.

Solved; I needed to format internal SD partition.
Thanks.
The Following User Says Thank You to javier.pc For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Find 7a Original Android Development by ThreadRank