Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Cannot get Retroarch and Xbox360 controller to work

OP quacka

9th July 2014, 01:15 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Nov 2007
I have tried many build of Retroarch and could not get the XBOX360 controller to work. I have read many posts people got this to work but I cannot replicate this.

The controler works ok outside in the menu and allow me to select the game. Once the game starts, I could only use Start button which brings up the RGUI and Back button which goes back to the Retroarch menu.

Anyone can give me any tips?

Also I am using the XBOX wireless dongle. If I leave this plug in, the Amazon Fire TV will start in Safe Mode. No idea
18th August 2014, 07:29 PM   |  #2  
Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2007
In the Retroarch input settings, if you disable auto detect you can scroll way down and enter custom mappings into controller 1. The left joystick was detected as dpad but only the dpad works for me in game.
19th August 2014, 10:47 PM   |  #3  
Member
Thanks Meter: 3
 
64 posts
Join Date:Joined: Sep 2010
I'm just going to copy and paste the post I just made and what I did to fix it.

I have tired the controller with Sev Zero and Deus Ex. I have also tried an Xbox 360 controller. They work in the Fire TV menu, but not in any of the games. Does anyone have any idea what is going on? The only thing I can think of is that somehow the buttons got mapped funky when I mapped them for XBMC using FireTV Side App Installer.


I figured it out. For some reason the Xbox 360 Dongle was causing the problem. I still had it plugged into the USB port. Once I removed that and restarted, everything seemed to work with the fire TV game controller.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes