Post Reply

Xbmc issue

OP clnzx2

17th August 2014, 02:13 AM   |  #1  
OP Senior Member
Thanks Meter: 120
 
278 posts
Join Date:Joined: Sep 2007
I have numerous devices on my network running xbmc with no issues at all. I am using a windows 7 based machine as a media server with typical smb shares. They work fine on all of my other devices which are windows, android, and Linux based. I rooted and installed xbmc on the fire TV with no problem. For the life of me I can't get the fire TV to see anything when I select smb. I have tried manually entering the shares which kinda works but it does not find all of the media and nothing will play. Any ideas? Thanks in advance.

Sent from my SM-N900V using Tapatalk
19th August 2014, 06:04 PM   |  #2  
OP Senior Member
Thanks Meter: 120
 
278 posts
Join Date:Joined: Sep 2007
Another question may be is anyone using smb shares successfully? Should I just switch to Linux on the server and use NFS shares?

Sent from my SM-N900V using Tapatalk
20th August 2014, 03:25 AM   |  #3  
Senior Member
Thanks Meter: 57
 
293 posts
Join Date:Joined: Jun 2007
Smb shares work fine for me off my Asus rt-n66u router.

Sent from my SCH-I545 using Tapatalk
20th August 2014, 04:48 AM   |  #4  
Senior Member
Thanks Meter: 105
 
267 posts
Join Date:Joined: Dec 2006
Quote:
Originally Posted by clnzx2

Another question may be is anyone using smb shares successfully? Should I just switch to Linux on the server and use NFS shares?

Sent from my SM-N900V using Tapatalk

Smb shares works fine for me. Have a networked SMB hard drive and a shared DVD drive from laptop. Can you browse to the shares or do they not show up at all?
20th August 2014, 05:34 AM   |  #5  
Senior Member
Thanks Meter: 199
 
754 posts
Join Date:Joined: Feb 2011
I'd never understood the issue with XBMC and network shares - until now. And now what I understand isn't a resolution or anything, but what a pain this is when it stops working.

I had solid SMB mounts for a long time. And then last night, all the network shares timed out continuously. Other devices in the house have no problem with them. This box can ping the media server, vice versa.

I also run NFS, and the DVD player can see the NFS shares, so I thought i'd try that. The fire TV NFS client can see the NFS server and the sharenames, but cannot get into any of them.

I don't know what's happened, I did not get an OTA and am still rooted, but suddenly neither SMB nor NFS work on the firetv. My DVD player can do the NFS mounts flawlessly. It's too bad, as this basically makes the FTV worthless to me.

Unfortunately, since there's no way I know of to truly reset the device, I'm not sure how to proceed. I've tried rebooting, I've tried updating to the latest launcherish XBMC, I've tried resetting the system and reinstalling XBMC - nada, except I was reminded how much I hate the setup video.

I'm well past the 100 bucks worth of annoyance at this point. The WDTV Live Plus never, ever gave me this kind of trouble. It couldn't stream Amazon video and at first this box seemed so much more capable but now? Meh.
Last edited by roustabout; 20th August 2014 at 05:36 AM.
20th August 2014, 07:45 AM   |  #6  
OP Senior Member
Thanks Meter: 120
 
278 posts
Join Date:Joined: Sep 2007
I can't even see the smb shares unless I manually enter them and then they quickly lose the password or quit working. I have wanted to switch to NFS for a while so may try that. Just blows my mind when the server and my other devices have been working for over 2 years through numerous versions of xbmc, windows, Linux, android, etc. I set my cheap android box up in 20min and the fire TV was looking the same until this happened. Does anyone have any ideas on stuff to try?

Sent from my SM-N900V using Tapatalk
20th August 2014, 02:44 PM   |  #7  
Senior Member
Thanks Meter: 105
 
267 posts
Join Date:Joined: Dec 2006
Quote:
Originally Posted by clnzx2

I can't even see the smb shares unless I manually enter them and then they quickly lose the password or quit working. I have wanted to switch to NFS for a while so may try that. Just blows my mind when the server and my other devices have been working for over 2 years through numerous versions of xbmc, windows, Linux, android, etc. I set my cheap android box up in 20min and the fire TV was looking the same until this happened. Does anyone have any ideas on stuff to try?

Sent from my SM-N900V using Tapatalk

Have you tried using ipaddress in place of server name? If that works, should probably make server ip static.

Sent from my SAMSUNG-SGH-I497 using Tapatalk
20th August 2014, 04:17 PM   |  #8  
OP Senior Member
Thanks Meter: 120
 
278 posts
Join Date:Joined: Sep 2007
Server IP is static and yes. Same results. The fire TV should be able to see the shares without me manually entering them anyway

Sent from my SM-N900V using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Fire TV Q&A, Help & Troubleshooting by ThreadRank