Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,290 Members 46,510 Now Online
XDA Developers Android and Mobile Development Forum

[Q] S5830i failed to mount data

Tip us?
 
iissmmaarrr
Old
(Last edited by iissmmaarrr; 1st September 2014 at 03:38 PM.)
#1  
iissmmaarrr's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Nov 2012
Location: Sarajevo
Default [Q] S5830i failed to mount data

So my aunt come to me (she lives outside country) and she have samsung galaxy ace s5830i and it worked fine with stock rom and everything (she just use it for calls) and it just turn it off and when she try to turn it on it wont pass samsung boot screen. She buyed new phone and give me this one if I make it work its mine (its great because i dont have phone) so I cant get into download mode to reinstall system I can get to recovery (thru adb shell) but cant move from reboot system now and when I choose that option it says failed to mount /data and reboots. PLEASE HELP ME PLEASEE
PS:I want to repair it my self, I do know litle about android develop but I cant fix this
EDIT: I make it work
 
cet.junior
Old
#2  
cet.junior's Avatar
Junior Member
Thanks Meter 1
Posts: 6
Join Date: Apr 2012
Location: Recife - PE

 
DONATE TO ME
Quote:
Originally Posted by iissmmaarrr View Post
So my aunt come to me (she lives outside country) and she have samsung galaxy ace s5830i and it worked fine with stock rom and everything (she just use it for calls) and it just turn it off and when she try to turn it on it wont pass samsung boot screen. She buyed new phone and give me this one if I make it work its mine (its great because i dont have phone) so I cant get into download mode to reinstall system I can get to recovery (thru adb shell) but cant move from reboot system now and when I choose that option it says failed to mount /data and reboots. PLEASE HELP ME PLEASEE
PS:I want to repair it my self, I do know litle about android develop but I cant fix this
EDIT: I make it work
How did you make it?
 
Benik3
Old
(Last edited by Benik3; 4th September 2014 at 01:29 AM.)
#3  
Benik3's Avatar
Senior Member
Thanks Meter 233
Posts: 819
Join Date: Feb 2012
Location: Pilsen - The City of Beer :)
I also want to know it, because I have similar problem!

My friends gave me his phone, because it unfortunately didn't want to boot.
I tried to reflash it with stock firmware, upload goes OK, but then when it install the ROM, it says "failed to mount /data (invalid argument)".
I tried flashing also with .pit repartition and splitting the one ROM file into separated PDA/phone/modem...

I also wanted to try to flash custom recovery and then custom ROM, but it doesn't want to mount SD card also

EDIT: Solved! Look at this guide
After flashing open australia FW (including bootloader and pit re-partition) phone is working again!
Then just reflash with yours correct firmware
Attached Images
File Type: jpg mobil.jpg - [Click for QR Code] (239.9 KB, 21 views)
Do you have problems? Post logs!!!
HTC Evo 3D GSM - 1.49.0007 S-OFF latest radio
4EXT Recovery Touch v1.0.0.6 RC1
ROM: CyanogenMod 11 by johnnyslt
kernel: included MiRaGe
 
iissmmaarrr
Old
#4  
iissmmaarrr's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Nov 2012
Location: Sarajevo
Quote:
Originally Posted by Benik3 View Post
I also want to know it, because I have similar problem!

My friends gave me his phone, because it unfortunately didn't want to boot.
I tried to reflash it with stock firmware, upload goes OK, but then when it install the ROM, it says "failed to mount /data (invalid argument)".
I tried flashing also with .pit repartition and splitting the one ROM file into separated PDA/phone/modem...

I also wanted to try to flash custom recovery and then custom ROM, but it doesn't want to mount SD card also

EDIT: Solved! Look at this guide
After flashing open australia FW (including bootloader and pit re-partition) phone is working again!
Then just reflash with yours correct firmware
I also solved my thru usb jig but I also establish problem that I have. My volume rocks dont work I need to repair them
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes