Post Reply

[Q] S5830i failed to mount data

OP iissmmaarrr

31st August 2014, 11:49 PM   |  #1  
iissmmaarrr's Avatar
OP Junior Member
Flag Sarajevo
Thanks Meter: 0
 
7 posts
Join Date:Joined: Nov 2012
More
So my aunt come to me (she lives outside country) and she have samsung galaxy ace s5830i and it worked fine with stock rom and everything (she just use it for calls) and it just turn it off and when she try to turn it on it wont pass samsung boot screen. She buyed new phone and give me this one if I make it work its mine (its great because i dont have phone) so I cant get into download mode to reinstall system I can get to recovery (thru adb shell) but cant move from reboot system now and when I choose that option it says failed to mount /data and reboots. PLEASE HELP ME PLEASEE
PS:I want to repair it my self, I do know litle about android develop but I cant fix this
EDIT: I make it work
Last edited by iissmmaarrr; 1st September 2014 at 03:38 PM.
3rd September 2014, 08:21 PM   |  #2  
cet.junior's Avatar
Junior Member
Flag Recife - PE
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Quote:
Originally Posted by iissmmaarrr

So my aunt come to me (she lives outside country) and she have samsung galaxy ace s5830i and it worked fine with stock rom and everything (she just use it for calls) and it just turn it off and when she try to turn it on it wont pass samsung boot screen. She buyed new phone and give me this one if I make it work its mine (its great because i dont have phone) so I cant get into download mode to reinstall system I can get to recovery (thru adb shell) but cant move from reboot system now and when I choose that option it says failed to mount /data and reboots. PLEASE HELP ME PLEASEE
PS:I want to repair it my self, I do know litle about android develop but I cant fix this
EDIT: I make it work

How did you make it?
3rd September 2014, 10:35 PM   |  #3  
Benik3's Avatar
Senior Member
Flag Pilsen - The City of Beer :)
Thanks Meter: 233
 
828 posts
Join Date:Joined: Feb 2012
More
I also want to know it, because I have similar problem!

My friends gave me his phone, because it unfortunately didn't want to boot.
I tried to reflash it with stock firmware, upload goes OK, but then when it install the ROM, it says "failed to mount /data (invalid argument)".
I tried flashing also with .pit repartition and splitting the one ROM file into separated PDA/phone/modem...

I also wanted to try to flash custom recovery and then custom ROM, but it doesn't want to mount SD card also

EDIT: Solved! Look at this guide
After flashing open australia FW (including bootloader and pit re-partition) phone is working again!
Then just reflash with yours correct firmware
Attached Images
File Type: jpg mobil.jpg - [Click for QR Code] (239.9 KB, 29 views)
Last edited by Benik3; 4th September 2014 at 01:29 AM.
5th September 2014, 12:21 AM   |  #4  
iissmmaarrr's Avatar
OP Junior Member
Flag Sarajevo
Thanks Meter: 0
 
7 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by Benik3

I also want to know it, because I have similar problem!

My friends gave me his phone, because it unfortunately didn't want to boot.
I tried to reflash it with stock firmware, upload goes OK, but then when it install the ROM, it says "failed to mount /data (invalid argument)".
I tried flashing also with .pit repartition and splitting the one ROM file into separated PDA/phone/modem...

I also wanted to try to flash custom recovery and then custom ROM, but it doesn't want to mount SD card also

EDIT: Solved! Look at this guide
After flashing open australia FW (including bootloader and pit re-partition) phone is working again!
Then just reflash with yours correct firmware

I also solved my thru usb jig but I also establish problem that I have. My volume rocks dont work I need to repair them
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes