Post Reply

[Q] Battery does not charge always!

OP qstar.inc

3rd July 2014, 11:07 AM   |  #1  
qstar.inc's Avatar
OP Member
Flag Dhaka
Thanks Meter: 6
 
39 posts
Join Date:Joined: Oct 2013
More
Hello, recently I'm having a problem with my Galaxy Core with charging!

This occurs randomly, few times only! Not always:
When I plug in the charger, as usual, it shows battery charging! Even after charging one hour, when charger is unplugged, the battery meter doesn't increase! I've tried restarting, cooling down battery, charging again, and it charged normally 100%. So, basically it does not bother me much, but just wanna know if this happens to anybody else, and as, I think, its a hardware problem, so I worry about it?

Another thing is if I connect my APACER B120 Mobile Bank, the phone doesn't charge, does not even show its plugged in. Other phones charges perfectly, even with the same cable. Has anyone tried charging with this, or any portable charger? Thanks!
5th July 2014, 04:58 AM   |  #2  
Member
Flag Purwokerto
Thanks Meter: 1
 
30 posts
Join Date:Joined: May 2012
More
sound like hardware problem man
7th July 2014, 12:12 AM   |  #3  
Senior Member
Thanks Meter: 35
 
130 posts
Join Date:Joined: Aug 2013
Make sure your usb cable is working and use the cable you got with the phone.
9th July 2014, 12:10 AM   |  #4  
qstar.inc's Avatar
OP Member
Flag Dhaka
Thanks Meter: 6
 
39 posts
Join Date:Joined: Oct 2013
More
Quote:
Originally Posted by afaquekhaja

Make sure your usb cable is working and use the cable you got with the phone.

I have only one cable, and it is the one I got with the phone. Cable works fine even on Tether/ReverseTether!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy Core Q&A, Help & Troubleshooting by ThreadRank