Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,045 Members 38,447 Now Online
XDA Developers Android and Mobile Development Forum

[Q] help, charging issue

Tip us?
 
kieran347
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Question [Q] help, charging issue

So I pay 45 a month for my Samsung galaxy mega 6.3 I've had it for a month and a half now and its a lovely phone, works well and everything, however all of a sudden I plug my charger in and it constantly flicks between charging and not charging (the little lightning bolt symbol appears and disappears constantly) whilst the cable is firmly plugged into the phone, this is when the screen started to flash at me and click on things I haven't touched , the most common thing it does is switch on driver mode , the back and options button flash at me and the screen switches on and off rapidly, I've reset the phone and tried a different battery and still the same result, its not as bad now, when I put the charger in this time the screen doesn't go weird it's fine its just my phone will charge but after 5-10 minutes it will stop charging again and I have to go and unplug it and plug it in again, this is seriously annoying so is it a malfunction with the phone? Is It something I've done? Is there an easy way to fix it? I need help please!
 
trurl3
Old
#2  
trurl3's Avatar
Senior Member
Thanks Meter 172
Posts: 618
Join Date: Apr 2011
Location: Warszawa
Is that the same when you charge your Mega through USB cable from PC? If yes, then it is phone's hardware problem, but if NOT, I would suggest to change charger.
Charging from PC is also possible, but the charging current is about 1/4 th of current from dedicated wall socket charger - the phone is charged although much less intensively.
Nominal charging current from wall socket charger is approx. 1.9 amp so if you need to find new one, choose wisely and accept only charger with 5V 2A specs.

Samsung Galaxy Mega GT-I9205 with MegaFire MJ2 V14X

Be smart, keep your files one click away @Dropbox. Sign up for free!
Wakelocks got you down? Click here for solution.
If I helped - plese hit
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes