FORUMS
Remove All Ads from XDA

(UBUNTU-tip) Unlock bootloader stuck at "Waiting for Device"

264 posts
Thanks Meter: 27
 
By photonmedia, Senior Member on 17th December 2011, 12:54 AM
Post Reply Subscribe to Thread Email Thread
you should have already edited your /etc/udev/rules.d/51-andorid.rules file to include this line:

Code:
SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
But in fastboot mode, the device shows up as "Google" so you also need to add an additional line to the above file so it looks like this:

Code:
SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
SUBSYSTEM=="usb", SYSFS{idVendor}=="18d1", MODE="0666"
Then issue an:
Code:
sudo service udev restart
Unplug and re-plug the device (while in fastboot mode) and try the command again:
Code:
fastboot oem unlock
Worked for me!
The Following User Says Thank You to photonmedia For This Useful Post: [ View ] Gift photonmedia Ad-Free
 
 
17th December 2011, 01:44 AM |#2  
Senior Member
Thanks Meter: 131
 
Donate to Me
More
You probably also could just run sudo before the command (either adb or fastboot) and it should work.

Sent from my Galaxy Nexus using XDA App
The Following User Says Thank You to Mills00013 For This Useful Post: [ View ] Gift Mills00013 Ad-Free
18th December 2011, 08:14 PM |#3  
Member
Flag Anaheim, CA
Thanks Meter: 27
 
Donate to Me
More
Works great.

Thanks!
20th April 2016, 08:32 PM |#4  
Junior Member
Thanks Meter: 0
 
More
New guy here
Can you explain this please
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes