Stylish Black Azure Theme for CM12

This black, grey and blue goodness will make your CM12 pop with cold contrast and neat transparencies. If … more

Smart Lock for Chrome Now Available for Chromebooks

Android 5.0 Lollipop introduced a useful feature titled Smart Lock, which kept your … more

Alibaba Breathes New Life Into Game-Console Maker Ouya

After asuccessful KickStarter campaign, Android console Ouya failed to become a … more

Use JSON to Dynamically Load Layouts with json2view

You normally use XML layouts for your applications, but what if you need a simpler way to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

(possible WIFI Fix) Let's try to figure out why WiFi stops auto scanning

OP blackhand1001

5th September 2013, 08:00 PM   |  #1  
blackhand1001's Avatar
OP Senior Member
Thanks Meter: 687
 
1,280 posts
Join Date:Joined: Sep 2011
Donate to Me
As many of you know, since the 4.3 update, WiFi on the galaxy nexus stops automatically scanning after going into deep sleep. The only way to get it to scan again is to go into the WiFi menu or toggle it on and off. Let's try to find which change in 4.3 broke this on the galaxy nexus. It works fine on both nexus 7s. Its also not related to any particular router as the issue is the phone doesn't scan for WiFi.

Sent from my Nexus 7 2013


Edit:

I think I may have found something. In /system/etc/wifi/wpa_supplicant_overlay.conf
Theres a line:
disable_scan_offload=1 (has to do with allowing scanning to be offloaded to the driver)


This line didn't exist in 4.2.2. Change it to 0 and reboot and see if your wifi scanning doesn't stop working after a while.

I just ran an errand and it connected perfect when I got home which is usually when it stops working.
Last edited by blackhand1001; 11th October 2013 at 10:26 PM.
The Following User Says Thank You to blackhand1001 For This Useful Post: [ View ]
6th September 2013, 08:08 AM   |  #2  
andQlimax's Avatar
Senior Member
Flag Rome
Thanks Meter: 914
 
2,412 posts
Join Date:Joined: Jul 2010
Donate to Me
More
I don't understand how Google do the tests..

They do testing ya?? I really have doubts

There are lots of network bugs to me, since years.. Like wifi drop with screen off in some conditions.. I can't accept that

Inviato dal mio Galaxy Nexus con Tapatalk 2
Last edited by andQlimax; 6th September 2013 at 08:33 AM.
11th October 2013, 09:35 PM   |  #3  
blackhand1001's Avatar
OP Senior Member
Thanks Meter: 687
 
1,280 posts
Join Date:Joined: Sep 2011
Donate to Me
Does anyone know the commit in aosp that added the always on wifi scanning for 4.3. I bet reverting it to the 4.2.2 behavior would get us working scanning. What good is always on scanning even when wifis off if it doesn't even work.
11th October 2013, 10:23 PM   |  #4  
blackhand1001's Avatar
OP Senior Member
Thanks Meter: 687
 
1,280 posts
Join Date:Joined: Sep 2011
Donate to Me
I think I may have found something. In /system/etc/wifi/wpa_supplicant_overlay.conf
Theres a line:
disable_scan_offload=1 (has to do with allowing scanning to be offloaded to the driver)


This line didn't exist in 4.2.2. Change it to 0 and reboot and see if your wifi scanning doesn't stop working after a while.

I just ran an errand and it connected perfect when I got home which is usually when it stops working.
12th October 2013, 02:06 PM   |  #5  
Ed V's Avatar
Senior Member
Nexus Island
Thanks Meter: 124
 
299 posts
Join Date:Joined: Jan 2013
More
You keep us informed, yes?

.
25th October 2013, 10:05 AM   |  #6  
thumm138's Avatar
Member
Thanks Meter: 6
 
39 posts
Join Date:Joined: Jun 2012
Gave this a try but still no luck.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes